wacom object 3.1 beta 5 broken in max6

    Nov 01 2011 | 12:34 am
    hi all.
    i cannot get data out of the wacom object when running in max6 (on osX). max5 it's fine. this is the version that comes with the cnmat objects.
    has anyone else managed to get this to work? i also cannot reach jean-marc- jmcouturier.com is a for sale domain.
    thank you!

    • Nov 01 2011 | 2:02 pm
      bump. anyone trying to use a wacom with max6?
    • Nov 01 2011 | 5:09 pm
      The same here, with a version 4.0 however. This seems to be his not so recently updated website: http://jmc.blueyeti.fr/home.html
      In the meantime, because of some issues with wacom, a while ago I made a standalone (IoR) that will send wacom data to max using udp.
      It can be downloaded from: http://www.jvkr.nl/home/Download.html
    • Nov 01 2011 | 7:32 pm
      I've been working on this object and it's a big pain in the neck. The current implementation relies on Carbon callbacks that won't work with Lion or Max 6. And, it seems that these features are not present in Cocoa -- or at least not without a prohibitive amount of convoluted effort.
      In the long term, I'm hoping to get Wacom support into the standard Max distribution. For the moment, running a standalone or another copy of Max 5 that sends data to Max 6 is your best workaround.
    • Nov 01 2011 | 7:44 pm
      Good to hear. Sorry for the woes.
    • Nov 02 2011 | 1:03 am
      @mzed - would you at all be interested in a collaborative effort on reviving this object?
    • Nov 05 2011 | 9:13 am
      @jvkr: I've downloaded your beautiful little app, and it seems to solve all my wacom worries, except for one: I can't get the nopointer feature to work. Tried setting both the local and remote port to 34903, but no response... Any ideas why?
    • Nov 10 2011 | 12:42 am
      I am seconding mzed to say that Wacom has never been really supportive with the music/hacking community, and working with the wacom object for years, every Mac/Max/Wacom update was painful ! So I ran into the same problem when moving to Max6. Thanks jvkr for the little app, it's sweet. But yes, it keeps dragging and clicking on my icons when I play :) The most flexible/reliable solution I found so far is you to create a patch in Max5 with the CNMAT wacom object, shaping and sending the OSC message that is the most appropriate for your usage, and then export it as an application. I tested it on Max6, 10.6 and 10.7, and everything works, including the nopointer.
      As it works fine for me, I'll add such an exported patch in the next update of uHs. I'll keep you posted there -> http://www.nicolasdalessandro.net/software/uhs/
    • Nov 10 2011 | 1:44 am
      http://www.nicolasdalessandro.net/software/wOsc.zip Just let me know if it breaks on some systems...
    • Nov 28 2011 | 10:58 pm
      I had the same problem with MAX6, but your little max5 app did the trick and is actually really nice to work with = cmd+tab switches on and off :)
      Still hoping for an integrated solution, but until: Thank you so much, Nicolas!!
    • Nov 30 2011 | 2:34 pm
      @kflak: just now saw your remark of a few weeks ago, sorry for that.
      > I can't get the nopointer feature to work. > Tried setting both the local and remote port to 34903, but no response...
      Both ports must be set to a unique value. The max patch that accompanies the app receives at port 34903 and sends to 34904. When IoR sends to (remote) port 34903 and receives at (local) port 34904 communication should be established. Just tested again to make sure this works. I noticed however that there might be an issue with setting the ports. After selecting and entering the value for both ports, the best way to deselect is to use the tab-key. The nopointer feature is working, but I didn't test with many wacom devices. Currently I am having a Graphire attached, the next days I will see chance to test with a few others.
      Hope this helps.
    • Dec 09 2011 | 8:12 pm
      Hi, all,
      On tour now without my wacom, but will play around with it again soon :-) Hope to get everything working then. Thanks for the help!
    • Dec 09 2011 | 11:39 pm
      IoR is a lifesaver right now, many thanks jvkr!