WaveShell Patch


    Apr 24 2009 | 5:28 pm
    Just upgraded to Max 5.07 and was happy to notice that WaveShell support was added to the vst~ object. How to do this is not in the vst~ help file but in the reference file. I thought I would share this simple patch that I setup to load a few of the Waves plugins I have.
    The main trick is that you need to send the name of the waveshell and the code of the waves plugin you want to use. To obtain a list of codes load the waveshell and send the vst~ object a printids message.
    Here is my simple patch... Hope it helps those of you wanting to integrate waves plugins into your patches or apps.
    Stefan

    • Apr 25 2009 | 5:01 pm
      hi,
      This is really great. I see your patch and can't figured out where i can find these names you use to call the plugins. It seams to be some code, where can i find it?
      Thanks
      Luis Marques
    • Apr 25 2009 | 5:21 pm
      I added a button to print all current Waves plugin codes to the max window. All you need to do is create your own custom menu and swap the codes in the waveshellguts subpatcher with the right codes.
      Stefan
    • Apr 27 2009 | 7:49 pm
      Hi, this is a great news. Thanks for sharing the patch, Stefan. It worked for me, but now I really need is loading different presets via MaxMSP. Is this possible ? I can dump the parameters, but they are named P1, P2...etc (number depends on PlugIn) and in the first view meaningless. sepp
    • Apr 28 2009 | 6:52 am
      If you open the VST~ help file you will see that sending it the read command will load a preset file. I hope that help.
      Stefan
    • Apr 28 2009 | 8:42 am
      Normally the read command works fine, but not for the WaveShell. I cannot load .xps (Q-Clone prestes) or .wir (IR1 presets), they are greyed out.
      sepp
      ......OS X.5.6, MaxMSP 5.0.7, WaveShell-VST 6.0.7.....
    • Apr 28 2009 | 3:15 pm
      I have not tried reading any presets in from the max end. I have just used the load buttons embedded in the waves plugin window and that works fine.
      You could send an email to Cycling as this could be considered a bug. Or it could just be that because Waves have decided to go their own proprietorial way that you are out of luck.
      It might be something as simple as adding a few file types to the list that read accepts on Cycling's end but I have no idea. I know its tough for Cycling to test these things as the Wave plugins are expensive and I don't think they are getting free copies.
      You could parse all of the parameters to number boxes which are looped back to the vst~ object and use pattr to create your own preset recall system. Not sure if you could get it to load specific reverb impulses though.
      I'm just happy that I can finally use a great sounding reverb in my patches.
      Stefan
    • Apr 28 2009 | 4:49 pm
      I really appreciate the waveshell implementation in MaxMSP 5.0.7. I will write to the cyc support for adding "load presets" via MaxMSP. The parameters, which the vst-object spits out for a Wave PlugIn (P1, P2...) are from the same amount as they show up in Live (but in Live with meaningfull names). Sending these parameters to vst, the wave parameter are changing... And in Live, choosing a preset in the Wave PlugIn , safe and open the Live-session will load the choosen preset. So there must be some way...
      sepp
    • May 27 2011 | 4:54 pm
      Thanks Stefan for your patch!!!!!
    • Apr 21 2013 | 11:28 pm
      WaveShell-VST 8.0.vst: no format VST exists
      in MaxMSP 6.1.2 at 64 bit. it's ok in 32 bit. Mac version
    • Apr 22 2013 | 4:57 am
      This error message usually tells us that your plug-in is not 64bit.
      If this is not the case please let us know
      -A
    • Nov 07 2013 | 9:01 pm
      I will write to the cyc support for adding “load presets” via MaxMSP.
      and what thay said?
      i have the same problem, i would like to load a specific reverb impulse from Max but i can't.
      i tried to use "write" message to create my preset and than "read" all parameter have been loaded but than max ask me to load manually the .wir file, i would like to automate this process from Max.
      Do you find a way to do?
      Mattia.
    • Feb 20 2014 | 6:19 pm
      Hi all,
      It seems that it don't works with the Waves V9.
      Any idea?
    • Feb 21 2014 | 1:57 pm
      Hi,
      What does not work? I use Waves V9 in Max 6 without problems, but I've not tried loading presets.
    • Feb 21 2014 | 2:12 pm
      Do you use the same patch? Have you made your own patch?
      There's something that I don't understand... Where are the waves 's vst? They are not in the vst folder. Thanks
    • Feb 21 2014 | 2:42 pm
      there have never been any VST plug-ins by waves (except the waveshell.)
    • Feb 21 2014 | 2:55 pm
      Yes... off course...
      I didn't know how the plug works... I didn't put the waveshell.vst in the folder....
    • Feb 21 2014 | 2:59 pm
      i see. yes for some reason their installers never do that for you.
    • Oct 13 2016 | 10:46 am
      Brilliant Patch! Thank you Stefan!
      Works with Max7.0.4 64bits and Waves 9.3 on a MacBook Pro early 2011.
      For any problem edit Stefan patch and change the name of the waveshell.vst for your version on the waveshell, edit the "p PrintListofCodesinMaxWindow"as well and use it to get the code of the plug in on the max window.
      The idea is to send to vst~ the message respecting this grammar:
      plug "^:/Library/Audio/Plug-Ins/VST/WaveShell-VST X.X.vst" SHQS
      where X.X is your version of the waveshell and SHQS the code of the plugin. here SHQS is the Modern Graphic EQ.
      Cheers
    • Nov 28 2016 | 2:22 am
      Thanks for this info! Just got this working with Max7.3.1 and my Waves Gold bundle.
    • Sep 11 2017 | 3:30 pm
      I'm getting a different output from printids compared to what is discussed here. I'm seeing stuff like this: vst~: H-Reverb Stereo/5.1: -1074120696 (?8) vst~: CLA-2A Stereo: -1074120696 (?8) vst~: Q4 Mono: -1074120696 (?8) vst~: H-Reverb 5.0: -1074120696 (?8)
      So I'm trying various things like set "H-Reverb 5.0" or set "-1074120696" etc but nothing seems to work. I was wondering if anyone has any ideas on this. I'm kind of assuming that I dont need to put the whole path into the plug message anymore since vsts paths seem to work better than they did in 2010.
    • Sep 13 2017 | 2:31 am
      here is a patch I'm using to try to switch plugins in the waveshell vst. I tried something similar with the au component but that didnt load anything. This loads one plugin but then I'm unable to change it-
    • May 02 2019 | 2:09 pm
      This post/patch helped me 10 years later in 2019 on Max 8, so thank you! As Adrian mentioned, you just need to get the change your WaveShell version and specific plugin unique ID.
      I found this doesn't work with the component shell or vst3 shell. This patch should be incorporated into the reference guide for VST plugins in Max. It is the only thing I've found to work in both Max and in an exported standalone.
    • May 03 2019 | 3:20 pm
      We were able to arrive at a solution to Kevin's problem that I think is worth adding to this thread. 'getsubnames' still works if you have Minimal/Fast plugin scanning enabled, but has no meaning if you have Complete/Slow scanning on, since the complete scanning resolves the subnames into normal named plugins which don't scan as shells anymore.
      I believe that we've disabled Complete/Slow scanning by default in standalones (and also in the main app).
      So you'll need to use the vstscan object with a scan 0 and enable Complete scanning mode in order to see the same thing you see in Max (AU and VST3 should still be available in fast scanning mode, also). I hope this is of some help to you all.
    • May 29 2019 | 9:34 pm
      I'm working with Max 7 and WaveShell3-VST 10.0_x64 on Windows. Nick's patch (with the WaveShell name updated) properly populates a dropdown with subnames, but plug messages with the subnames and subname messages with the subname don't seem to do anything; vst~ loads the first subname in the list and nothing else. Update: I've downloaded the Max 8 demo, and the vstscan with scan 0 properly populates the subnames in the plugin list. The plugins needs to be instantiated with the input channels specified (such as [vst~ 4 4 "NX Ambisonics Quad"] to open with the right number of inputs for multichannel plugins.