way to get @interp 1 square pixels with pak dim and @adapt 1 in open GL?


    Apr 13 2011 | 9:27 pm
    In the jit.gl.videoplane help file, using a pak dim object with a number like 5 being sent as the width then sent to jit.qt.movie with the interp $1 message set to 1 you get a blocky pixelated effect.
    However, if I am using @adapt 1 on my jit.qt.movie (following the suggestions of many of the forums) I can only get the dim to change if I pass the output of jit.qt.movie to another matrix and use pak dim messages there. However, in this patch I am working on I still can't seem to achieve the same sharp, blocky pixelated effect I'm after.
    I can't locate the element that is rendering it smoothly to disable or switch it off. I've tried blend_mode, different jit.gl.render drawing methods, looking at slab help files.
    stumped...

    • Apr 14 2011 | 12:17 pm
      not sure if this is helps-- you might try sending "@filter nearest" and "adapt 0" to your slab
    • Apr 14 2011 | 8:50 pm
      @interp 0 if sending the matrix directly to gl.videoplane or another matrix.
      @filter none if sending first to a gl.texture or gl.slab.
      check it:
    • Apr 15 2011 | 6:47 pm
      Thanks Robert. I appreciate your explanation and example patch.
      (I'm wondering now if all the custom object coloring is what makes my 'compressed' patch here in the forum sooo long)