weird copy/paste behavior with multiple patches open

    Feb 07 2011 | 12:45 am
    hi, im having a problem in max that is starting to frustrate me a bit. when i copy an object or part of a patch window and then try to paste it into another patch window sometimes it works and sometimes it pastes into the patch that i copied from even if its behind the patch window i want to paste into. ive tried toggling all window active to see if that made a difference but it didnt.
    anyone else have this problem? any advice or help? im sure im missing something really simple here....

    • Feb 07 2011 | 2:00 am
      Have you tried with or without the "All windows active" options?
    • Feb 07 2011 | 2:54 am
      yes i have, and it still acts funny.
    • Feb 07 2011 | 3:42 am
      I thought it was just me. Glad to hear someone else is experiencing this.
    • Feb 07 2011 | 6:43 pm
      perhaps an update by C74 could fix this? anyone else having this problem?
      its kind of driving me crazy.....
    • Feb 07 2011 | 6:50 pm
      This is not a known issue. Could you post your OS, computer model and version of Max installed? A reliable set of steps to reproduce would be helpful.
      Also, do you have any third party externals installed, say, Max Toolbox, or something like that?
    • Feb 07 2011 | 8:37 pm
      Hey Ben,
      MacBook Pro, Intel Core 2 Duo, 2.4 GHz, L2 Cache: 3 MB, Memory: 2 GB, OS 10.6.6, MaxMSP v. 5.1.7.
      I can't consistently make it happen, but it seems to happen most when I have two different maxpat documents open at the same time. I'll be working in one of the files, and then switch to the other one and the toolbar is grayed out. If I try to paste something that I had copied from the previous window it doesn't paste it in the frontmost window, but in the window from which I just copied out. Clicking on the window, it's title bar or tool bar doesn't help. The only third party externals I use are Tap.Tools, but I'm not using them in any of the projects I was having trouble with. Hope that helps.
    • Feb 07 2011 | 8:52 pm
      Thanks for the info. I can't seem to repro, so it would seem that there is something happening that is machine-specific. Do you run any OS level utilities or scripts, anything that manages windows, does keyboard shortcuts, or something like that? Do you use Spaces? If so, try disabling anything like this that might be running in the background.
      I'd recommend a clean install and see if you can repro before installing any third party externals:
      To clean out Max 5 entirely, remove these items:
      ~/Library/Preferences/Max5 Preferences Folder /Applications/Max5
      Then download and reinstall the latest Max 5 release:
    • Feb 07 2011 | 9:00 pm
      Hey Ben,
      I'm swamped for the next couple of days, but will have time later in the week to give this a shot. I'll report back. Thanks for the suggestions.
    • Feb 18 2011 | 3:33 pm
      hi all, i've been getting this as well, but only since 5.1.7 (i think...) the behaviour is similar when i try to save a patch, the frontmost patcher isn't saved until the other ones are closed. this doesn't happen consistently, though i have no idea what triggers it. k Mac OSX 10.4.11 2.16GHz Intel Core 2 Duo 2GB 667 MHz DDR2 SDRAM
    • Feb 18 2011 | 8:28 pm
      I've had similar strangeness with floating patcher windows, some of the control-keys aren't functional in them (but the mouse is, so to paste I use right-click). Floating windows seem to get "partial" key focus, it's kind of strange. Don't know if that applies in your case though.
      I've also had some strangeness where the "dirty bit" indicator of a patch stops working. In this case (XP) it's an asterisk next to the patcher name that shows up when you make a change to the patch. Sometimes this will stop appearing, even after saving and then changing something. Nothing seems to actually be wrong, though, as the patch always saves correctly. But the asterisk thing won't correct itself until I close and re-open the patch.
      Anyway, maybe partially related. These aren't a big deal, but it's a little unnerving when the dirty bit thing stops working. To be safe I save and close to fix it.
    • Feb 18 2011 | 10:51 pm
      I would imagine that these kinds of problems are frustrating. If anyone has any reliable steps to repro, please post with system specs and version of Max installed. Be sure you are running vanilla Max with no 3rd party OS level utilities that might interact with window management.
    • Feb 19 2011 | 7:25 am
      Okay, here's what I do that consistently recreates it.
      1. Create a new patcher and place an object in it. 2. Save the patcher but leave it open. 3. Minimize the patcher to the dock 4. Create a second patcher and place an object in it. 5. Save the patcher with a different name from the first and leave it open. 6. Copy the object you created in the second patcher. 7. Bring the first patcher back to the Desktop. 8. With the first patcher as the frontmost patcher, attempt to paste the object you copied into that patcher.
      When I do that, it pastes the object into the back (second) patcher instead of the front (first) one.
      MacBook Pro, Intel Core 2 Duo, 2.4 GHz, L2 Cache: 3 MB, Memory: 2 GB, OS 10.6.6, MaxMSP v. 5.1.7.
    • Feb 19 2011 | 9:20 am
      I have the impression that along the way the policy has changed on what max considers the active window (on mac osx). It seems now easier then it once was, with all windows active enabled, to interact with patchers that are in the background. Not an active menubar (wasn't it once like that?) but an active toolbar denotes what window has the focus, is that correct?
      The minimizing business appears to create a graphical glitch whereby it is not anymore possible to distinguish which window has focus. When a window is de-minimized, it appears in front, but notice how it's toolbar is not activated. But neither has the other window now an active toolbar, even though it is still active. The result of pasting appears in this window. Windows management, I believe, is not the strongest point of mac os.
    • Feb 19 2011 | 5:34 pm
      Although windows management may not be a strong point of the Mac OS, I never had this problem with Max until recently. I don't recall whether the problem began after I updated Max to 5.1.7, or updated the OS to 10.6.6, but this is a recent change in behavior.
    • Feb 19 2011 | 8:26 pm
      Thanks, Brian, for posting a clear example. I now have a vague memory of something like this coming up a while back. Regardless, I can repro and we will take a closer look.
    • Feb 20 2011 | 12:35 pm
      my suspicion is that it may well be the Max update as i haven't updated my OS in quite some time.
      Mac OSX 10.4.11 2.16GHz Intel Core 2 Duo 2GB 667 MHz DDR2 SDRAM
    • Mar 29 2011 | 4:12 am
      thanks for looking into this ben, its a really annoying glitch!
    • Sep 17 2011 | 10:27 pm
      Any progress on this issue?
      MacBook Pro, Intel Core 2 Duo, 2.4 GHz, L2 Cache: 3 MB, Memory: 2 GB, OS 10.6.8, MaxMSP v. 5.1.9.