what happened to jit.qt.grab?!?

    Apr 24 2014 | 2:12 am
    hi, i am having some quite serious bugs with jit.qt.grab, most of the time resulting in max to quit instantly without any error messages. this patch used to work fine like two months ago...
    the patch captures an incoming 1080psf25 video signal via "jit.qt.grab 1280 720 @unique 1 @interp 1 @colormode uyvy". this used to work fine a while ago, however now this results in an instant max shut down. it becomes slightly more stable if i do all these commands one after another (like first capture 1920x1080, then rescale with interpolation in a separate matrix, then convert to uyvy via jit.argb2uyvy) but this uses up too much performance and does also quit randomly from time to time.
    i'm running max 6.1.7 (in 32 bit mode) on macos 10.9.2 with a video signal coming in over a blackmagic express card (driver version 10.1).
    any help is appreciated a lot! k

    • Apr 24 2014 | 11:57 am
      after some further testing i think the culprit is the blackmagic driver... anyway, if anyone should have similar problems with this card i'd be highly interested. k
    • Apr 24 2014 | 12:29 pm
      I have very bad experience with Max 6.1.x (32/64bit) and [jit.gt.grab] / [jit.grab] even when I'm using just iSight camera on my laptop. Max typically crashes or producing artefacts in captured image after some config changes (to reproduce: try change resolution and/or video device a few times) - even if I'm using help patches for [jit.gt.grab] / [jit.grab].
      I'm testing every new update since 6.1 was released and in my opinion [jit.gt.grab] / [jit.grab] is still unstable. Very frustrating for me, 'cause I'm working with cameras a lot...
    • Apr 24 2014 | 5:41 pm
      hey guys, other than the reported issues with isights not working on 10.9 (which was addressed in the 6.1.6 update) i'm not aware of these issues.
      i know it's a little confusing, but with 10.9 we had to abandon the legacy quicktime drivers by default, and use the qtkit drivers for both 32 and 64.
      we are still not entirely clear on weather the legacy quicktime drivers will work for certain cameras/drivers on 32 bit 10.9, so i'd be interested to here some details.
      have you tried switching the default driver via the usealtgrab message? details here: https://cycling74.com/forums/jit-qt-grab-jit-grab-bug-settings-message-not-recognized/
    • Apr 25 2014 | 3:32 pm
      Yes I tested usealtgrab too - strange, but the result is always the same: max crashes (just quit, not special messages displayed). During tests I'm using the help-patches for [jit.gt.grab] / [jit.grab], and typically no external cameras connected to my computer. A few changes like resolution (via "dim" message or parameter box) and vdevice (even with iSight only, eg. if I "change" device into the same, by selecting "FaceTime HD Camera" in [umenu]) and... crash.
      Apple's AV foundation may be the real reason... I'm not sure it's a bug inside Max, but maybe there is a method to workaround the bug.
      From the other hand: this problem looks like something "max-related" - eg. if I'm dealing with iSight (or different cameras) with Processing everything works fine.
      Btw. this reminds me one thing... camera handling routine in Processing has a "feature", I would like to have in Jitter too: in Processing is possible to list "native" camera (or other video device) resolutions and framerates.
    • Apr 25 2014 | 5:02 pm
      i did not get down to the bottom of the problem yet but switching inputs/resolutions is definitely an issue. if i just select everything carefully one after another it works... at least most of the time. i'll write more when i have more insight.
      some other question, just wondering: i know video guys should stick to 32bit (what i do) however i noticed with 64bit, that vdevice only lists my internal camera, no external one. should it or is this one of the features still to come?
      best k