Why does this texture Mapping to Mesh does not work?


    Nov 13 2012 | 11:18 pm
    I am doing shape transformations using a gridshape, xfade, and jit.expr shapes to Mesh, everything works fine but when I try to add a texture or movie to the jit.gl.mesh I get color changes instead of the video on the shape that can be altered via texmap
    here is an example patch - ( i have tried a variety of texturing techniques , even using qt.movie @adapt 1 + slabs nothing seems to work, always get color change instead of texture map..... the texture map Max help examples work fine so It is all a bit strange>. does jit.expr has something to do with it? I need the jit.expr
    Thanks for the help

    • Nov 14 2012 | 12:00 am
      humm thi is is not the best example since you only have to change the planecount to 5 , my patch has a matrixoutput 1 from gridshape combined with matrix output 2 to jit.expr both going to a jit.xfade to give me a shape in gl.mesh that I can transform... there no matter how I change the planecounts it still gives me no texmap just random colors
    • Nov 14 2012 | 12:45 am
      Okay already figured it out. thanks
    • Aug 08 2017 | 5:45 pm
      hi sebastian and others, this thread is not the most recent, but in case ur reading this, id appreciate some insight into how you've achieved the crossfade between gridshape and jitexpr...
      ...im trying to crossfade between a dynamic matrix (coming from wave-forms) and a static obj (polygon-based), and am struggling to find a solution... have tried with xfade, as well, but now it seems i have to go more low-level with jitgen and/or lua...