Why this patch doesn't work under poly~?

    Sep 11 2012 | 7:12 pm
    I have a feeling that this will become a stupid question. But I haven't found the answer yet so what ever.
    I have made a 4 operator FM patch. When put it inside the [poly~], it can only produce one sound at any given moment.
    I suspect it's due to that I use [send~] and [receive~] in the [4opFMsub] subpatch (They are strictly inside the subpatch). However, from what I searched in the form, the problem should be solved in Max 6.0.4 (I use 6.0.7). Also I tried the same patch in Max 5 and the result is the same.
    I attached the whole patch. You can load sound preset by click the read button inside the [4opFMsub] patch, and load either json file in the patches/ folder.
    Thanks for any suggestion.

    • Sep 12 2012 | 9:03 pm
      Still haven't figure it out. Anyone can suggest some possible cause?
    • Sep 13 2012 | 7:58 am
      Well, this is so strange. To find the root of the problem, I made a very simple [poly~] patch very similar to the simple_poly example in MSP tutorial 21, and it dosen't work.
      The only difference is that I use a [function] for amplitude envelop while the tutorial example use a message directly. How can that make such a difference?
      In the attached image, [testpoly~] works while the [testpoly2~] doesn't.
    • Sep 13 2012 | 8:39 am
      In your FM patch, as your pattr system is in the voice, you first need to read a preset file and recall a preset in each voices you may use. If you send open 2 to the poly~, you'll see there is no preset in the second voice, and no sound is generated.
      I would rather put the whole pattr system in test4op.maxpat rather than in 4opFMsub.maxpat.
    • Sep 14 2012 | 6:26 am
      Now I understand what the problem is ! Thanks!