Window Zoom Oddities

    Mar 25 2010 | 8:49 pm
    According to the [thispatcher] help file, a message of (window zoom 0, window exec) to [thispatcher] should restore the window to it's "unzoomed" size. However, it doesn't seem to work. I can't get the example in the help file to work either. "Zoom 1" works, just not "zoom 0."
    The behavior of the zoom message is also different than if you actually click the little zoom button. The zoom 1 message puts the title bar of the window behind the menubar, while clicking the little zoom button puts the title bar right below the menubar.
    I haven't tried this yet on a PC, just on my Mac, so all my comments above are related to the Mac platform. OS 10.5.8, Max 5.1.3.

    • Mar 26 2010 | 4:54 am
      Okay, I just tried this in Windows and it seems to work fine. On a Mac, it zooms out, but doesn't zoom back in.
    • Mar 28 2010 | 3:36 am
      Is this a bug, or am I not doing something correctly?
    • Mar 28 2010 | 7:05 am
      Confirmed, same software & system versions.
    • Oct 28 2010 | 4:59 pm
      having this same problem on mac - Max 5.1.5
    • Oct 28 2010 | 6:42 pm
      Thanks for bringing this up again, window zoom 0 is indeed broken on mac. You can use a 'window size' message to restore it to the dimensions you want.