Write message / ~buffer object - OSX 10.6.8 write permission problem?

    Feb 15 2013 | 9:22 pm
    I'm wondering if anyone has had experience of this particular problem...
    This doesn't happen for me on either Windows 7 or on OSX 10.8.2, but a user of my standalone has reported problems when trying to write the contents of a ~buffer object to disk on OSX 10.6.8. He can save it to his desktop but not to an extra internal hard drive.
    I've yet to discover from him whether the file just doesn't appear or whether there's any kind of error reported.
    As I can't replicate the problem myself, I'm wondering if file writing permissions on the Mac itself (as opposed to my Max standalone) is likely to be causing this problem? And also whether it's something connected with his particular version of OSX?
    Has anyone encountered anything similar?
    Thanks :)

    • Feb 15 2013 | 10:36 pm
      I have a bit more info now. He's writing to a second internal hard drive (presumably on a Mac Pro) and the file apparently just doesn't show up. A friend of mine has tested on OSX 10.6.8 and can write to any folder without a problem (although she doesn't have a second internal drive). So I'm guessing it's writing to a second internal drive that's the problem as opposed to the OSX version?
    • Feb 15 2013 | 10:42 pm
      I am on OSX 10.6.8 and would be happy to test the standalone if you would like. Only have one internal hard drive, but can test on an external.
    • Feb 15 2013 | 10:48 pm
      That would be much appreciated, thank you. I'll PM you a link.
    • Feb 15 2013 | 11:39 pm
      Everything works great when writing to the desktop or external hard drive. I tried to write the file to a folder that was read-only and it produced the same behavior that your user reports of the file. Max does report this error: "buffer~: can't make file Untitled.aif, err -1". You could use the [error] object to notify users that the file was not written, but everything seems to work as it should the way it is.
    • Feb 15 2013 | 11:52 pm
      Excellent. Thank you. So it's sounding very like like his second internal drive could just be set to read-only rather than it being something OS-specific (which was my fear!). Good, that's a relief!
    • Feb 21 2013 | 11:39 am
      OK, I suggested to my user that it could be the permissions settings on his drive. He checked this and confirmed that where he's saving is marked as 'read-write' but he's still not able to save the file.
      He's running a Mac Pro, OSX 10.6.8 and the problem only occurs when saving to a secondary internal drive. He can write to Desktop, Documents, etc with no problems.
      Does anyone please have any further suggestions as to what the problem may be? Or would anyone with a iMac Pro with a secondary internal drive mind testing?
    • Feb 21 2013 | 12:13 pm
      There is an option to ignore ownership, in the info panel of a disk. Maybe that helps.
    • Feb 21 2013 | 1:53 pm
      Thanks jvkr. I'll check...
    • Feb 21 2013 | 3:11 pm
      OK, he's confirmed that 'ignore ownership' is selected on the drive and that read & write permissions are set for 'system' and 'everyone', but still can't save the file to this drive.
      Any further suggestions would be greatly appreciated. Thanks.