Avoid texture interpolation for small matrices


    Jul 14 2013 | 9:59 am
    Hello everybody,
    this is much more a theoretical issue, than a practical one. Anyway...
    please have a look at the patch below:
    I am generating a very simple texture, made of 7 coloured bars, actually a 7x1 matrix.
    When I send it to texture, I get interpolation, thus the bars fade smoothly into each other (this is what you see choosing tex1 in the example patch).
    To get solid bars, I need to resize the matrix to 320x240 (which is the corresponding value of "dest_dim" in the gl.render. I tried changing dest_dim value, but nothing happened), you can see the desired effect in tex2.
    As for now, resizing the matrix is not a great issue, but I'd like to know if there is some way to turn off texture interpolation, so one can use very small matrices and (i guess) save some CPU in very stressing patches.

    • Jul 14 2013 | 3:51 pm
      set @filter none on your jit.gl.texture
    • Jul 14 2013 | 7:02 pm
      Thank you Rob, that's perfect.