Back Faces Rendering Question


    Jan 29 2017 | 10:33 pm
    I'm getting some weird rendering with this patch where the back faces sort of slice out as they rotate. What in the rendering pipeline causes this? Is there a setting I'm missing in order to draw the inside consistently?
    Thanks:)
    Max Patcher
    In Max, select New From Clipboard.

    • Jan 30 2017 | 5:35 pm
      I consulted the tutorial 33 on blendmodes, and the backface slicing effect is still happening even when I get semi transparent or full alpha on the front faces. Interestingly, when I set @cull_faces 2, the artifact goes away and all of the back faces display totally consistently.
      I would like this striped shape to intersect with other geometry going around, so the @depth_enable 0, @layer x approach is less desirable. Using two meshes to display front/back separately is getting closer to what I'm looking for though.
      Any other tips?
      Max Patcher
      In Max, select New From Clipboard.
    • Jan 30 2017 | 5:41 pm
      using two meshes with front / back culling enabled is the solution. you can parent them both to a single jit.anim.node object for convenience with spatial transforms:
      Max Patcher
      In Max, select New From Clipboard.
    • Jan 30 2017 | 5:46 pm
      OK thanks Rob.