Blending particles from geometry shader


    Sep 11 2021 | 7:29 am
    Hello, I use a jit.gl.mesh @draw_mode points @blend_enable 1 @blend_mode 6 7 @shader postProcess. The postProcess shader creates several points from each vertex using a geometry program that calls EmitVertex() multiple times. Is it a general limitation that these emitted vertices do not blend resp. ignore the blend mode - e.g. 2 vertices a red one (RGB = 1, 0, 0) and a green one (RGB = 0,1,0) at the same position result in a green rendering and not in yellow ? It looks like the vertices that have been created first with EmitVertex() are hidden behind the vertices that are created after.

    • Sep 13 2021 | 3:48 pm
      do you have depth disabled (@depth_enable 0) ?
    • Sep 15 2021 | 9:54 pm
      OK found it. @blend_mode 6 7 is not working. @blend_mode 6 1 gives the required result.