Build script... where is it in Max 7?


    Jun 30 2016 | 4:21 pm
    I wanted to build a standalone application, and before in Max 6 it would come up with the build script editor. Now, in Max 7, it just builds my .app, though. While I would still like to include an icon, for example. Has it moved?

    • Jul 01 2016 | 10:34 am
      This seems to be a bug in 7.2.3, as this guy DOES get the window: https://www.youtube.com/watch?v=SIzrCgLkZpM
    • Jul 01 2016 | 10:38 am
      ...it DOES work when I just have one patch, but it doesn't when I try to build an app from a Max Project.
    • Nov 27 2016 | 7:04 pm
      I have the exact same issue MAAARK mentioned above. I have built standalone apps many times using Max 6. In a recent attempt to build from a project in Max 7, I was unable to get the Collective Editor to show when choosing "Build Collective / Application" from the file menu of my top-level patcher in my project - goes straight to the dialogue box for choosing the name/location/extension of the standalone without any ability to set up the build script or use an existing one. It also does not work when using the same option under the "Manage Project" icon on the Project Window.
      I am using Windows 10; Max 7.3.1. As MAAARK suggested, I also tested with a blank patcher that is not part of a project, and the Collective Editor did correctly show when choosing Build Collective / Application in that instance. However, if I then save that blank patch as a new project, the Collective Editor will no longer show when attempting to build from the top level patcher of that project.
      Anyone know of a workaround for this? I remember having problems using Max 6 where choosing to Build from the Project Window would not show the Collective Editor, but the File Menu selection for Build has always worked for me until now.
    • Aug 15 2017 | 12:09 am
      Any further news on this subject I too would like to enter script items, something simple such as an App icon and so on yet I cannot locate the Build Window that we used to have?
    • Oct 22 2017 | 12:11 am
      still nothing about this with 7.3.4 ...
    • Aug 24 2018 | 2:18 pm
      Hi,
      I have the same issue in Max 7.3.5 (on Mac). Any news about it, please?
    • Oct 24 2018 | 9:48 am
      Same here.
    • Oct 24 2018 | 10:02 am
      Hi,
      This is fixed in MAX 8 here on my side.
    • Nov 23 2018 | 3:54 pm
      surely I won't have to upgrade to achieve this.
      If the patch is saved in project mode it creates a project dialogue box where you can add an application image / external media such as audio or video files...
      then build as standalone
      Not sure if it as robust as the Script Builder but worked for what I needed.