fpic not keeping presentation mode attribute


    Oct 13 2015 | 4:18 am
    Hello all,
    I'm experiencing a problem with fpic where it doesn't keep its presentation mode after the patch has been saved and reopened. All I'm doing is setting two fpics as the background, and they are swapping alphas (like in the help file for fpic). I tried moving the image to the 'root' folder of the patch, and I tried recreating the problem in a new patch.
    When I made a new patch to try to recreate the problem I used the same image files and set them up in presentation mode like I did in the other patch, just without anything else the other patch had. The fpic objects saved their presentation mode information just fine. So it must be something in my original patch, right? I also tried deleting the fpic objects in the original patch and starting over with new ones, twice. And I tried messing around with different attributes to see if some were causing the problem, nothing changed.
    I would love to post the patch, but it is an absurdly large 'copy compressed' for some reason, I just tried to a couple times and it really blew this post up to a couple hundred pages or something.
    So I guess my question is does anyone else have issues with fpic not keeping its presentation mode information?
    Thanks,
    Nicholas

    • Oct 13 2015 | 2:16 pm
      +1
      i've had loads if problems with fpics changing size and even their image-file after saving and reopening.
    • Oct 14 2015 | 4:37 pm
      *bump*
      while its a decent hour of a weekday...
    • Oct 20 2015 | 5:59 am
      OK,
      My problem was that my [fpic] objects were not keeping their presentation attributes in a particular patch. I figured out a workaround to this bug; it's a confirmed bug at this point.
      Originally I made [fpic], then went into the inspector to toggle attributes and load an image file. Every time I would save and reopen the patch the [fpic] would lose its presentation attribute. So I tried writing in the attributes as I made the object [fpic @presentation 1 @embed 1 @ignoreclick 1 @autofit 1 @background 1]. Still, the presentation attribute would not stick (I also tried variations of the order in which the attributes were manually typed in). Then I tried making the object with just the presentation attribute [fpic @presentation 1] and going into the inspector for the rest, since I wasn't having problems with any of the other attributes except presentation in the first place, and it worked!
      Voila.
      Thanks for the help.. ('
    • May 07 2016 | 9:08 pm
      I'm having the same exact issue at the moment. Although fpic seems to sometimes retain the @presentation attribute, the moment I move or resize the file in presentation mode, it loses everything.
      So it's a confirmed bug from c74? (I was gonna submit a bug report now) If so, not promising that it's so many months later with the bug not being addressed.
      At first doing the trick where you name it [fpic @presentation 1] then search for the image works, but the moment I change the destination rectangle, or tick 'fixed aspect ratio' or 'scale to box' it loses its attributes.
      Does anyone know of any other workarounds here?
      I'm basically using a transparent .png to act as a mask for other UI elements (waveform~). I set it up and it looks fine, but the moment I save and reopen the patch, fpic loses all of its attributes (as well as the image itself, even if @embed 1 is on).
    • May 09 2016 | 11:39 am
      I've submitted this as a bug report and made a patch that reproduces the problem easily.