groove~ @timestretch - doesnt work. Please help!


    Jun 02 2015 | 11:06 am
    Hello. Im using 3 groove~ objects inside my patch. I have a toggle switch for timestretch on/off. But every time I open my patch the timestretching is not working. The only way to make them work is to create a new msp object(any object works) somewhere in the patch, and boom, everything starts working again. The standard speed+pitch works fine, but the timestretch wont respond to either "timestretch $1" or "pitchshiftcent $1". Ive tried to set the attribute inside the groove object to both "@timestretch 1 and 0". Neither has any effect..
    Im using a macbook pro. Got the 7.03 version and latest osx.
    Anybody knows whats going on?

    • Jun 02 2015 | 1:00 pm
      Switching the cpu off and back on also seems works.
    • Jun 02 2015 | 1:51 pm
      here is the guts of my time stretching groove that i use regularly. i added some temporary controls on the right. see if works for you.
      Max Patcher
      In Max, select New From Clipboard.
      `
    • Jun 02 2015 | 5:08 pm
      Could you comment that patch for us? It's a bit hard to read without annotations, I find. Cheers.
    • Jun 02 2015 | 6:10 pm
      Max Patcher
      In Max, select New From Clipboard.
      @wetterberg kind of labeled it a bit.
    • Jun 02 2015 | 7:01 pm
      muchos gracias.
    • Jun 02 2015 | 8:20 pm
      @WIL Thanks for your reply. I fixed it, I think.
      Timestretching suddenly worked normally again after a little swapping of objects.. groove~ didnt like to receive messages through the sprintf object. Especially for switching buffer. There was something strange going on with the info~ too. Not sure what though..