HELP : standalone strange behaviour


    Apr 07 2018 | 10:51 am
    Hello, I 'm working on an installation for a museum and I noticed a behaviour I don't understand. The installation starts with a waiting phase. When one or another of the 2 physical push buttons is pressed, the main phase of the show starts. It involves playing a video and audio file, DMX lights control, text display. During this phase, the buttons are inhibitted. At the end of this phase, the waiting phase starts again.
    My standalone is triggered when the computer starts up (Windows 10, Task Scheduler) and after several tests I noticed that even if the standalone works normally when I launch it manually (hours of tests) , when the same standalone is launched by the Task Scheduler, the buttons don't have the same behaviour : they aren't totally inhibitted during the main phase, Just after the standalone starts, most of the time the buttons don't work at all...
    My question is : has someone experienced issues or have advices with the Windows 10's Task Scheduler ? I join the triggering part of my patch in case the problem is here...
    dev config : Windows 10 64 bits, Max 7.3.5 64bits the installation runs on a brand new Dell Optiplex 3050, Win 10 64 bits (no other softwares installed)
    Thanks for reading, any help appreciated !

    • Apr 07 2018 | 11:40 am
      are there any start up settings that need to be applied to the scheduled task manager for full operation ? maybe the task needs to be the last task that is scheduled, or has the app been put in background and isn't picking up initial commands? afraid I don't use windows 10. just some guesses.
    • Apr 07 2018 | 3:02 pm
      Thanks Ibenny. In fact I had already delayed the launch of my standalone : 1 min after startup. But the more I read about the Task Scheduler, the more I understand it's a very powerfull but complicated tool. A program launched this way has more (or less) ressources allowed than launched manually. So it could be the cause of the issues I noticed Still lot to learn...
      So, I'm still looking for help in order to force the main window of my standalone to be in the foreground...
    • Apr 08 2018 | 8:33 am
      I found a workaround : I made a script with AutoHotkey : https://www.autohotkey.com/ in order to make my standalone always on top.