How to disable cord's automatic connection?

    Mar 19 2015 | 6:58 pm
    A simple question. Is there any way to get rid of the cords automatically hooking to objects? If I approach an object within a distance with a cord and let go it hooks up automatically to it. I do not want this function and would like to get rid of it, hopefully without using the segmented patch cords feature. So, if I let go of the cable it will not hook up to anything unless I am over the inlet/outlet.
    My apologies if this question has been asked before, I haven't been able to find an answer.
    I am using Max 7.0.2 on a Macbook Pro, OS X 10.9.5.
    Thank you, Irving.

    • Nov 12 2017 | 1:38 am
      I too would love to stop that feature. It is causing a lot of trouble while editing very dense patches created in Max 6 where this annoying feature did not exist. Is it possible that this feature was introduced without any way of disabling it?
    • Nov 12 2017 | 4:59 pm
      also for me this feature is very annoying. of course it could be useful sometimes but that's almost never, hehe. i think it would become more useful than annoying if it didn't have such a large auto-connect radius, it just connects to the closest object, even if it's quite far away.
      anyway, better calibration for it please, or at least a disable option.
    • Nov 18 2017 | 3:01 pm
      I hope this is noticed. Most annoying thing for me, too! Maybe it's my clicking style or my small object sizes, but if you'd see me patching, you would instantly understand that this autoconnect feature needs to be optional at least. For me, it very often accidentally happens when I try to drag the drag-dots of patchcords or the object itself. The click hits the outlet and starts a cord-connection. This is the moment where you are already forced to hit escape because releasing the mouse button will create an unwanted cord connection. Nobody else fighting with this?
    • Nov 18 2017 | 3:30 pm
      Have you tried activating "segmented patch cords"?
    • Nov 18 2017 | 6:54 pm
      Ok, that helps a little bit. It solves the problem of unwanted autoconnections. It doesn't help with the fact that you can NOT abort cord connection dragging by simply releasing the mousebutton. And I don't want to use segmented cords if i don't need to. And cmon, how hard could it be for Cycling to implement another checkbox in prefs to disable "autoconnect"?
    • Nov 18 2017 | 8:05 pm
      Amen brother Olsen. I am not sure which is more annoying, the auto-connect, or the sticky segmented cords. I have wasted so many hours tracing bad connections made inadvertently in complicated and dense patches because of the auto-connect feature.
      Cycling please give us a Preferences checkbox to defeat auto-connect. Please have pity on us.
    • Nov 18 2017 | 11:52 pm
      That’s your real problem! —It is causing a lot of trouble while editing very dense patches
    • Nov 19 2017 | 12:12 pm
      perhaps the best would be to make an option to set the radius of auto-connect, if it had a small radius it could be quite useful. this way if you want to disable it you can just set the radius to zero
    • Nov 19 2017 | 2:28 pm
      It went up from Max6 to Max7 in a very perceivable way. And the 'grab' area for reconnecting patch cables shrunk too.
      I don't do much (any really) patching in Max6 these days, but doing it for a few minutes feels luxurious with regards to cable moving.
    • Nov 19 2017 | 2:34 pm
      I miss Max 6 for many things, not the least of which is the lack of this annoying auto-connect feature. Indeed a control of the radius or sensitivity would be great thing for Cylcing to add or simply add a Preferences checkbox to go back to the Max 6 behavior.
      I wish there are many such "Max 6 behavior" checkboxes in the Preferences panel of Max 7!!