jit.gl.node & M4L issue


    May 31 2018 | 5:50 pm
    Hi,
    I'd like to know if there are some known limitation using jit.gl.node and texture apply in MaxForLive. Or perhaps jit.gl.pass and GL stuff chain. I'm not able to get a patch working in M4L using such a chain. The patch works fine in Max 7.

    • Jun 04 2018 | 7:15 pm
      feel free to post your patch here, and I'll take a look. should not be any limitations in this area.
    • Jun 11 2018 | 4:26 pm
      steps to get it running?
      I open your patch in Max and all I see is a black window.
    • Jun 12 2018 | 11:03 am
      Yes indeed. Go to light tab and set Z pos to -2 with slider or numbox below Or set off enable in nurbs tab then set on enable & automatic for gridshape tab and set Z light to +2. I can't understand why light need to be set to -2 for nurbs but + 2 for gridshape, since they both are placed to position 0. 0. 0. But I deal with. My problem comes from Live. I get nothing but the black screen when the patch is pushed in Live.
    • Jun 13 2018 | 4:15 pm
      ok, please try and narrow down the problem to a simple patch.
      it could be related to contexts not being properly set, so make sure all your jit.gl objects have the context argument or drawto attribute set appropriately.
      make sure if you are using MSP processing that you're creating an audio device rather than a MIDI device (I think, I'm pretty ignorant to MFL behavior).