jit.grab in windows 10 sluggish


    Dec 12 2015 | 1:54 am
    since updating to windows 10 i have very weired behaviour of jit.grab: sometimes it works just fine, but then suddenly my framerate drops from a (theoretical) 400 to about 5 fps randomly (and might as well stay like that for a while but might also return to normal after some time). does anyone know something about this?
    on windows 8 my patch worked just fine. with windows 10 this happens with jit.dx.grab as well as with jit.qt.grab and also with all max versions 6 and 7, both in 32 and 64 bit. also it makes no difference if i use the built in camera or a blackmagic card. however as soon as i replace jit.dx.grab eg. with the camera output of a kinect everything works as it should. i did not test this thorougly but the bug might be somehow related to jit.window because if i delete that and send the output to a jit.pwindow instead, it seems to work fine.
    any leads? k

    • Feb 04 2018 | 5:04 am
      FWIW, I was just having a similar issue. Turned out, in my case, that the webcam I have ( a Logitech 120) was doing its own image correction.
      Sending the 'settings' message to the jit.grab opens a menu where there are toggles for auto gain etc. Turned them off, and the stream is buttery smooth.
    • Oct 08 2018 | 9:42 am
      Hello, How to store these settings in order not to set them each time the Patch is run ?
      Thanks
    • Oct 11 2018 | 3:29 pm
      Hi Alain,
      The settings were entirely on the webcam's side of things. In my case there was another GUI made by Logitech that opens up when you send the 'settings' message to the jit.grab while the webcam was selected from the jit.grab's list of devices.
      The settings saved automatically