Jit.grab Resolution


    Jun 12 2018 | 3:14 pm
    Jit.grab is acting funny, I set it's dim to 1280x720 from both isight camera and a logitech web camera. Both should be 1280 720. I ask it to adapt and it goes to 160x120. When I turn that off and force 1280 720 the fps gui object says it switch to 1280x720, but it looks the exact same as 160x120. I've updated max, restarted the machine, and tried all the video engines. I've never run into this issue before, bug in the update?

    • Jun 12 2018 | 4:06 pm
      I'm experiencing the same thing (160x120) with an ELP generic USB cam, but not my MacBook's built in Facetime cam. Also I can't change the engine from avf although my preferences are set to viddll.
      I'm on High Sierra 10.13.4
      On another Mac mini running Max 7.3.4 and El Capitan 10.11.6 the problem doesn't happen.
    • Jun 12 2018 | 5:08 pm
      I'm guessing there is a change in OS behavior that's causing this. you probably need to explicitly set your format to the highest resolution. in the patch below (taken from the help patch), select your device and then click "getformatlist", and select the format 1280x720 (or whatever's highest), and then open your device.
      there is no viddll backed jit.grab. both engines use the same AVF backend.
      Max Patcher
      In Max, select New From Clipboard.
    • Jun 12 2018 | 5:46 pm
      Awesome. Thanks Rob. That works for me.
      Good to know about the backend also.
    • Jun 14 2018 | 4:33 pm
      It was for sure OS behavior, my colleague Ryan suggested I open iSight in another app, once I had it going in quicktime (1280x720) and then opened grab in Max it worked at the correct res. Thanks for the response Rob and SLO.