kinematic flag; bodies still pass through each other


    Dec 07 2017 | 6:31 pm
    Hi again team
    Still working through Rob's great jit.phys.multiple video. As part of a larger patch, I am moving the 'floor' of a jit.world box up and down, sometimes quite quickly. Despite setting the @kinematic flag to the floor, a sphere (or other bodies, I guess) can pass through the floor - which is undesired. How can I ensure that one jit.phys.body cannot pass through another? Small example patch below

    • Dec 07 2017 | 7:03 pm
      but you don't have kinematic set to 1? also, the mass shouldn't be 0. works for me when i fix those settings: glad those videos are still useful!
    • Dec 07 2017 | 10:29 pm
      Ah Rob, the man himself! I've recently been asked (strongly encouraged) to teach an Introduction to Jitter module at uni, about which I know only a little, which is why I only found your jit.phys.multiple tutorial video very recently. I've been mainly covering OpenGL and CV stuff. And I have to say your video blew my mind, coming from a strictly MSP background ;) Hours of endless fun, especially as we're planning to use interactive sensors (Leap Motion, FSRs, multimodal mappings etc). Thanks again.
    • Dec 07 2017 | 10:54 pm
      The speed of motion, of the floor, still causes the original problem. I set the flags as you said, and the ball will still occasionally 'clip' through the floor, if the floor is moving quickly). Is it because my Max machine (Windoze) can't handle the graphics? I don't think so, because your tutorial patch runs very well on the same machine. #confused.com
      please tell me if this version still causes the moving ball to occasionally and randomly pass through the moving floor
      ps paste from clipboard option is greyed out on this browser
    • Dec 08 2017 | 4:56 pm
      i have to increase the rate to 4 to see any pass-throughs. one thing you can try is to increase the resolution of the simulation by increasing the fixedtimestep and maxsubsteps attributes to the phys.world (you can set these via the "sendphys" message). try 120 or 240 for fixedtimestep, and simply crank up maxsubsteps to 10 or so.
    • Jun 13 2019 | 6:12 pm
      I am having this problem too. I have tried changing the two parameters Rob mentioned but objects still clip through each other at higher speeds. Is there something else that can be done to fix this?