Leap Motion

    Jun 20 2013 | 1:59 pm
    Can leap motion work with max? I think it would be ideal for the game I am working on to control some jitter objects

    • Jun 20 2013 | 2:01 pm
      sure. Google "leap motion max" for the aka external, to begin with. There's lots of stuff out there already.
    • Jun 20 2013 | 2:37 pm
      Okay, cheers.
      Is it compatible with Ms Windows 8 do you know?
    • Jun 20 2013 | 2:38 pm
      Not to worry, I have found it works great with Windows 8
    • Jun 20 2013 | 4:06 pm
      Do you have a way to get the LEAP data into Max on Windows? I've only been able to do it on Mac with aka.leapmotion.
    • Jun 20 2013 | 4:10 pm
      No, I just presumed there would be something available to do that. Will do a bit of research and let you know
    • Jun 21 2013 | 1:40 pm
      Hello guys, there https://github.com/N1ckFG/LeapToOsc/tree/master/bin Leap to OSC osx/win32
    • Aug 09 2013 | 1:33 pm
      hi there,
      how could I receive the data from leap to osc in max using the osc-route object ? I can't find out how to "adress the right route", if that makes sense.
      thanks !
      PS : I'm on OS 10.8 / Max 6.1
    • Sep 04 2013 | 11:11 am
      I just received my leap, played with the demo apps and am a little underwhelmed. Is it really resource intensive (I do realtime audio processing so that would be a concern!
    • Sep 04 2013 | 11:37 am
      hey Bas - snap. I got mine about a couple of weeks ago - played with it for an hour, was similarly underwhelmed and it hasn't been out of the box since... I'll play with it more when I get some time, but I don't see it as accurate enough for doing anything musically unless you're happy at having random elements introduced also (which some people maybe)
    • Sep 04 2013 | 12:39 pm
      how could I receive the data from leap to osc in max using the osc-route object ? I can’t find out how to “adress the right route”, if that makes sense.
      Grab the aka.leapmotion external from github.
      Use the prepend object to add routing prefixes to the data you want to send via osc.
      Pick up the odot library from CNMAT. Specifically check out o.route instead of osc-route... It's what the original creators of osc use in their own Max patches.
    • Sep 05 2013 | 4:47 pm
      metamax - what are your findings? are you doing 'useful' stuff with the leap?
    • Sep 06 2013 | 9:59 am
      hm 'usefulstuf' my arm is gettig tired...
      tried to put the controller between keyboard and monitor. mapped two fingers up to the edit on/off in max. and five vinger down brings up the max forum in safari.
      and five finger up goes back to max while being in safari .
      it seems to work while working on the laptop . at home (on the desktop) i use a wacom . dont want to put down the pencil ...
      bee trying to rotate the leap controller so its pointing towards the user but no succes yet ...
    • Nov 05 2013 | 9:34 am
      What would you guys consider the best tool for now to interface with the leap on windows? Considering also performance issues, the leapmotion uses lots of ressources.
    • Nov 25 2013 | 2:41 pm
      How do i get the aka.leapmotion to work as nothing happens when I'm using it?! Nothing appears on the screen except a black box. Driving me nuts as I need it for a project I'm doing. Cheers in advance
    • Mar 17 2014 | 4:19 am
      You should try out the very early beta www.leapformax.com
      This site isn't even in google yet (20140315-05:19 GMT+1) :-)
    • Mar 17 2014 | 8:56 am
      Hey Leapformax, that seems nice but : -how is nodejs complicated to install ? -how does that solution compare to other int erms of performance ? i mean is it more performant ? thanks!
    • Mar 26 2014 | 5:38 am
      I am also having the same problems. I can't seem to find the best tool for Windows 8. Has anyone had any luck?
    • May 26 2014 | 4:04 pm
      FWIW, I've been using the leap as my main performance interface as long as it's been around, mostly with a customized version of aka.leapmotion. I've been looking at leapformax, hoping to get the v2 beta data out (much better tracking) without complete success at this point, but I can tell you that it's giving me a faster update rate than aka.leapmotion, somewhat to my surprise. one frame in aka.leapmotion comes in around 80-90 fps, in leapformax, I'm getting 95-105. It's a bit fiddly to install, and you have to go to the terminal to run it, but the results are good, and only about a 4 on the geekitude scale. I've also found you can throw the .json data into a dict, and that speeds up things a bit as well -- I can post the code if anyone is interested.
    • May 26 2014 | 9:29 pm
      Hi, I will be very interested in your leapformax patch. Particularly passing the datas to dict Do you work on windows? My max patch have been crash in all the time on osx thanks
    • May 26 2014 | 10:26 pm
      I'm sure many of you know about this, but Geco works really well for me.
    • May 26 2014 | 10:26 pm
      Though it does add a bit of overhead, especially if you keep its interface window open.
    • May 27 2014 | 12:07 am
      Doesn't cover all possible data, or gestures, but you should be able to use it as a model to get what you want. The tricky part is the changing size of the hand and finger arrays, but that's done. You may just need to alter the [dict.unpack] objects...
    • Jun 01 2014 | 12:00 am
      Has anyone managed to get the new V2 data into max yet? https://www.leapmotion.com/blog/leap-motion-v2-tracking-now-in-public-developer-beta/
    • Jun 01 2014 | 2:19 am
      Writing a processing sketch to send the data over OSC, already having some success. Will post when complete.
    • Jun 01 2014 | 3:02 am
      I think a few people are working on it right now, so keep your eyes peeled. Maybe very soon.
    • Jun 01 2014 | 5:05 pm
      sounds good M, looking forward to it! I'll keep going with my processing to OSC hack job - already got me some quick results this morning: https://www.youtube.com/watch?v=Q0yR8YhYcmU
    • Jun 01 2014 | 11:25 pm
      Jbailey. Looks great !
    • Jun 07 2014 | 8:57 pm
      Thanks Andro, more progress (getting finger orientations now), https://vimeo.com/97619364 Code is too sloppy to post, but promise to get something up if no one else does soon.
    • Jul 05 2014 | 3:07 pm
      www.leapformax.com Just got updated! -deferlow for not crashing max (with or without overdrive) -focus for connecting to v6.json (beta skeleton tracking) -complete sample patch for retrieving skeletal data
    • Jul 05 2014 | 3:11 pm
      http://www.leapformax.com Just got updated! -deferlow for not crashing max (with or without overdrive) -focus for connecting to v6.json (beta skeleton tracking) -complete sample patch for retrieving skeletal data
    • Jul 05 2014 | 5:28 pm
      In the spirit of Leapformax's release, here's a compiled processing patch I'm calling LeapOSC JeremyLeapOSC. It's just Leap Motion for Processing's basic example mashed up with oscP5 so that it send hand and finger orientation and position out over OSC on port 5001 (more info on Leap for processing here:https://github.com/voidplus/leap-motion-processing)
      This is completely untested on anything but my own setup. You can download the app and source here https://dl.dropboxusercontent.com/u/12369342/JeremyLeapOSC.zip
      If there's interest I'll invest some time in making things better. Peace,
    • Sep 22 2014 | 10:23 pm
      Just got updated! 20140922 -UPDATE -Complete revolution, first of all - Absolutely - NO-MORE-MEMORY-ISSUE. -The tcpigola max patches are now independent from leapmotion, they can be used for ANY JSON OBJECT -dict approach - a bit slower but stable- great for unpredictable JSON objects and where you cannot predict the fields you will be interested in reading, also very good for integrating with preexisting dict based systems. -props approach - very fast - select exacly the fields you want and have them outputted as an array, then you can do whatever you want .. for example unpack it. -sadam.udpreceiver external is now needed.
    • Sep 23 2014 | 2:54 am
      The non working concept of our webtool is also posted, later, hopefully in a few days you all can experience a fully working demo of our patches in the browser!!!
      -AND YES, it will allow to read leapmotion data LIVE for PERFECT test!!!
      Talk about cool..... :-)
      Check the non working concept in your browser now! on our homepage http://www.leapformax.com, just under the download link.
    • Sep 24 2014 | 7:38 am
      I think I installed everything correctly. In the terminal it says it is connected to the leap option data service.
      In max, when running tcpigola-dict-v0.4 when I bang it I get this... js: dataparser-dict.js: Javascript SyntaxError: JSON.parse, line 21 js: error calling function bang [dataparser-dict.js]
      When I click message box I get this... dict: no dictionary named hands, cannot get value dict: index out of range for key hands::0::id
      and in the props patch I get this... js: dataparser-props.js: Javascript SyntaxError: JSON.parse, line 23 js: error calling function bang [dataparser-props.js]
    • Sep 24 2014 | 11:20 am
      Maybe you didn't receive anything yet... its possible some firwall or need for admi privileges?
      IT will give error in the very first frame if not data is received...
      Also i invite you to download the versione from the website, not this one, that was really just for mathieu.. the latest version download already been TESTED by different people, and improved on dict performanes It's stil name 0.4PREVIEW,
      for the bang to work it has to have reeived some bytes that contains some JSON in ascii form, via UDP. use tcpigolo-offline to test if you don't have the leap motion device, or tpigolo.js for the real thing
      tpiglo is preonfigured to work with leap device drivers >=2 but can work with previous if you hange the url in the final part of tcpigolo.js to "v3" instead of v6
    • Sep 24 2014 | 4:57 pm
      I'm not having any trouble with the dict patch. You might want to confirm that you are getting data out of [sadam.Udpreceive] with a message box or something.
      There is an issue with the props patch -- if there is no hand visible when you start banging it, or when you take your hand away, you get that error. I've been in touch with the developer about it. It's in the dataparser-props js -- it needs some checking added for when one of the props comes up null.
    • Sep 28 2014 | 1:51 pm
      www.leapformax.com got updated to v0.5 - unlocking performances on a minor note, the website help pages have been greatly improved.
    • Sep 28 2014 | 7:38 pm
      v0.4 worked for me. When running tcpigolo-ascii.js in terminal I get "Error: Cannot find module 'websocket'" This didn't happen with tcpigolo.js, but I deleted so I'm not sure if it would work now or not. Everything was same, though since I have ran installer for websockets again but still get the same error.
      Thanks for making this! ChristopherO
    • Sep 28 2014 | 7:44 pm
      You are very welcome! also you should try having a look on the renewed setup pages, if you still did not.
      If using windows I highly reccomand the auto setup script. ---- If using some other OS I strongly suggest use of npm now. Wether portable or installed the "npm" tool is available on all os. Try uninstalling websockets module and reinstalling it using "npm"
      EDIT: care for the s in "websockets"EDIT: there are significant improvements in the patches alone. if you need the tcpigolo-ascii.js this is UNCHANGED from v0.4 PREVIEW.ùyou can use the v0.5 pathes with tcpigolo.js coming from v0.4 PREVIEW.
    • Sep 28 2014 | 7:56 pm
    • Jan 16 2015 | 2:02 pm
      does aka.leapmotion works in max7 ????
    • Feb 14 2015 | 1:14 pm
      Hi there I finally installed leapformax and it works real nice. I'm using the ascii file but I don't know how to retrieve other movements such as swipe and circle and tap. I tried the logical attempts, like props hands[0].swipeStrength with no success, is there somewhere a precise list of these? thanks
    • Apr 04 2015 | 7:19 am
      leapformax site is no longer available. :-(
    • Apr 04 2015 | 10:38 am
    • Apr 12 2015 | 9:37 pm
      Hi all. I found this on my travels. I actually couldn't get tcpigoleap to work. But this is really really easy to get runninghttp://julesfrancoise.com/leapmotion/
    • Mar 16 2016 | 12:07 am
      There is a new external working really smooth with windows 10 here max 7.1 64bit . Free at ircam http://ismm.ircam.fr/leapmotion/
    • Dec 20 2016 | 5:18 am
      Thanks Carlo, your link proved to be the only one I could get working! Max 7.3 64 bit. Dropped it into the /externals path and worked straight away.