Loading Audio Unit / Component plugins

    Jan 29 2013 | 4:55 pm
    I would like to open plugins that are stored on my disk in Library/Audio/plug-Ins/Components.
    I thought plugs in this folder where Audio Unit plugin ; but the vst~ object is not able to open these plugins.
    So here are my questions : - Components plugins are not Audio Unit plugin ? - How can I open these Components plugins ?

    • Jan 29 2013 | 10:05 pm
      What audio unit plugins did you try? Component files are a type of bundled file and audio units are bundled as components. You should be able to open AU's with the vst~ object. What audio units did you try?
    • Jan 29 2013 | 10:48 pm
      I've come across a few AU's that vst~ wont load, giving a 'no format AudioUnit exists' error - most of U-he's plugs, for example. Apparently this is connected to multiple plugs being package into a single file, or something - see this post for more: http://www.kvraudio.com/forum/viewtopic.php?t=354478&postdays=0&postorder=asc&start=1185 I'd be interested to know what Dan is referring to when he says Cycling does provide a way to access these plugs... Cheers Roger
    • Jan 30 2013 | 10:04 am
      There is also the au~ external http://www.michaelnorris.info/software/au.html , you may have a try with that.
    • Jan 30 2013 | 10:50 am
      Thanks to all your replies !
      @gwsounddsg : I tried a lot of AU plugins (for example +binaural.component from soundhack, or Absynth 5.component from Native Instruments). When I install an AU plugin, I always have a Plug.component added in my library, that's why I'm focusing on .component files. Actually no .component plugin works, I've got more than 400 of them. But in ABleton Live these plugins work, and are put in "Audio Unit" folder.
      @roger.carruthers : so for me, none of the 440 plugs work... I'm correct AU plugs are in Libraray/Audio/Plug-INs/Components ? Some should work, you say...
      @LSka : I tried the au~ external. It works for some plugs, but I'm not able to access all my plugs - even if the "bad" plugs work under Ableton Live, under "AU" section.
    • Jan 30 2013 | 10:58 am
      @LSka : the au~ gives me the list of files put in /VST folder I think (+some extra AU not put in /Components). I can't find a folder dedicated to explicit AU plugins (such as .aufx ?).
    • Jan 30 2013 | 11:15 am
      .component is an audiounit, there is no other dedicated extension.
      If you double click on the vst~ object after you load the plugin via message "plug", the main plugin window will open. You can also open the main window via "open" message.
    • Jan 30 2013 | 3:38 pm
      It occurs to me that the OP might not have Max6. Earlier versions do not load AudioUnits (.component files) unless you have Tim Place's au~ external.
      In addition, it's good to remember that if your vst/audiounit has spaces in its name, you need to use quotation marks around it for it to load properly: [vst~ "Plugin Name.component"]
    • Feb 05 2013 | 2:20 pm
      @roger.carruthers - Hi Roger! Regarding the "multiple plugins per .component file" issue - what I was alluding to in that KVR thread is that in Max 6, when you start the app, it automatically creates a list of all of your AU plugins currently in your /Library/Audio/Plug-Ins/Components folder. It puts this list into ~/Library/Application Support/Cycling '74/AudioUnits/ , and the list of plugins is represented as .auinfo files, These .auinfo files are used to populate the "file" submenu of the "wheel" that appears to the left of the vst~ object within Max.
      You will note that Max correctly pulls out multiple .auinfo files from .components that have multiple plugins within them - for example, Uhe's Zebra2.component gives rise to three .auinfo files (plugins) - Zebra2.auinfo, Zebralette.auinfo, and ZRev.auinfo. For these plugins, you should load them into the vst~ object using either the wheel, or specify them using the .auinfo name (e.g. vst~ Zebra2.auinfo). If you try with vst~ Zebra2.component , you will get an error.
      Hope that helps. For the original poster, I think lowenstern's comment above about the necessity of quotes around filenames with spaces in them is probably the key...
    • Feb 05 2013 | 6:48 pm
      Hi Dan, thanks for that - I'd never really noticed the file menu in the wheel; Max 6 is full of surprises! Anyway, sadly not a solution that applies to standalones, which was my problem, though it's good to know there is a workaround in Max itself. Is this something that Cycling could/should see to with vst~ ? Cheers Roger
    • Feb 05 2013 | 7:02 pm
      thanks to all of you for all your replies. Sorry I was busy for work this week, I did not have time to reply. I will try to solve my problem using all of your popoal and let you know.
      Thanks again for your help, that's really nice !
    • Feb 05 2013 | 10:33 pm
      @Roger - for sure it would make things simpler is there was some way directly within vst~ to get at these types of plugins, but there are workarounds, even for a standalone; for example, you could populate a umenu with the contents of that AudioUnits folder (it also gets created in a standalone's Application Support folder, i.e. ~/Library/Application Support/YOUR_APP_NAME/AudioUnits/ ), and then use that to load the AU into the vst~....
    • Feb 06 2013 | 12:55 pm
      Nice one! That's a win-win because it also puts both AU and VST plugs into one folder, whereas at the moment I'm having to use a script to switch between vst and au menus. I wasn't seeing an Application Support folder for my standalone, but guessed that it might be connected to the database attribute in the standalone object (which rather unhelpfully just gives 'database' as an explanation in the documentation!), and checking that seems to have done the trick. I'm also having a look through your Expo74 standalone presentation, which is full of useful stuff, so thanks again, Roger
    • Feb 06 2013 | 4:29 pm
      The standalone folder in the Application Support folder is created by setting the Preferences File Name attribute in the standalone object to be equal to your app's name...
    • Feb 06 2013 | 4:40 pm
      Yes, I got that (once I looked in the right Library folder!), but without the database attribute ticked, it doesn't produce the Audiounits folder; should be in the documentation, really. It also seems I was a bit hasty about wishing the VST's and AU's into one folder; the wheel menu manages to do that, but it's obviously more complex than just populating a menu from the auinfo folder. No worries though, it's still a lot better picking up all the AU plugs this way, cheers Roger
    • Feb 06 2013 | 5:59 pm
      Didn't know that about the AudioUnits folder not being created without the database attribute ticked, thanks!!
    • Aug 09 2013 | 11:07 pm
      so I am still not able to plug Ambience reverb unit by Smartelectronix into vst~. I am running MaxMSP in 64bit mode rewired to Logic Pro X. I get the 'Ambience.auinfo: no format AudioUnit exists' error.
      The plugin I am using is 64bit, loads and functions perfectly in Logic Pro X.
      What am I missing here?
    • Aug 12 2013 | 11:44 am
      Did you try loading the AU using the wheel? It may be that the 64 bit version has a unique .auinfo name that you are not aware of...
    • Sep 06 2013 | 4:55 pm
      Well, that's what I was trying to do and it didn't work. But now I have a problem even stranger. I can see no list by using the wheel. When I click on the 'files' on the wheel, it simply does nothing. What does this have to do with?
    • Sep 06 2013 | 5:23 pm
      Not sure I'm afraid...
    • Sep 06 2013 | 5:31 pm
      Hey guys, is the vst~ help file "plugin Names" tab not working right? This kind of JS access to the DB is how it is envisaged that plugin names may be harvested by standalones.
      From a comment in the JS
      /*By default, the Max database is not used by the Max runtime or in standalones.
      If you wish to enable the database for use in a standalone, check the "Database" attribute in the inspector for the standalone object
      If you wish to enable the database in the Max runtime application, create a text file in the c74:/init folder and add the following line to it:
      max db.enable 1;
      Also - it's working fine for me in x64 Mac.
    • Sep 06 2013 | 5:44 pm
      Hi Andrew,
      Does the Max database know whether the plugin is an effect or an instrument? If so, how might one tweak the Javascript to get at that info - ideally to separate effects and instruments into two different menus?
    • Sep 06 2013 | 6:35 pm
      Hi Dan,
      No I don't think there is a crossplatform way to do that in Max currently
    • Sep 06 2013 | 6:37 pm
      I settle for Mac only to start? :-)
    • Mar 14 2014 | 1:57 pm
      @Dan Nigrin -- having the same problem-- I am not able to access some of my *.component plugins, (no spaces, that is not the problem). Here's a question about what you wrote about the .auinfo files...
      Regarding the “multiple plugins per .component file” issue – what I was alluding to in that KVR thread is that in Max 6, when you start the app, it automatically creates a list of all of your AU plugins currently in your /Library/Audio/Plug-Ins/Components folder. It puts this list into ~/Library/Application Support/Cycling ’74/AudioUnits/ , and the list of plugins is represented as .auinfo files, These .auinfo files are used to populate the “file” submenu of the “wheel” that appears to the left of the vst~ object within Max.
      The .auinfo files for the non-working plugins are simply not being created (checking in directory ~/Library/Application Support/Cycling ’74/AudioUnits/..)
      Any idea why that might be happening ?
    • Mar 14 2014 | 1:57 pm
    • Mar 16 2014 | 11:29 am
      Not sure really - are there NO .auinfo files, or just not the ones for a set of specific plugins you're interested in? If the latter, then perhaps those plugins are not passing some sort of AU validation or something? Just guessing.
    • Mar 23 2014 | 6:53 pm
      using the object vst on Max 64 bit i can’t load Tal-Reverb-2. Actually i can load it if i choose the .component file by plug message. If i write the component name like “vst~ Tal-Reverb-2″, it doesn’t work.
      I tried the 32 bit plug in version with max 32 bit mode and everything’s good. Can anyone help me to find out the correct name to put on vst~?
    • Mar 23 2014 | 6:55 pm
      P.s. there're not the .auinfo files in ~/Library/Application Support/Cycling ’74/AudioUnits/ ...
    • Mar 23 2014 | 7:01 pm
      I sorted it... I put the full path into vst~ and now it works. Is there a way to get the short name?
    • Mar 23 2014 | 7:27 pm
      Can't use audio units in MaxMSP. I can't see them in /Library/Audio/Plug-ins nor can I use them by creating the object vst~ with a plug-in name. Any solutions?
      PS: using Max 6.1.6
    • Mar 23 2014 | 7:51 pm
      OK, the problem was with AUMatrixReverb. Only works in 64-bit mode...
    • Jun 01 2016 | 1:09 pm
      I'm not sure if this issue is fixed, but i'm having the same problem (specifically with ambience.component by Magnus Jonsson). Both in 32 and 64 bit it wont't open the plugin, not with the full name or by dragging. I hope someone could shine some light on this.