Max 6.1.6 Released

    Dec 10 2013 | 5:39 pm
    We are happy to announce the release of Max 6.1.6. Although there are some additional bug fixes, the primary impetus for this release is to fix up a handful of Java-related issues, especially related to Mac OS 10.9.
    You can download it here:
    Thanks, -Ben
    Fixed Bugs: • attrui/inspector: properly displays certain numbers • buffer~: fix for crash when writing to invalid or unauthorized directory on Windows 32/64 • cycle~: no longer crashes with 'set' message in certain circumstances • docs: misc improvements for documentation usage by 3rd party developers • equals~ etc: backwards compatibility for when incorrectly connected • jit.anim.*: fix for breakage when context changes • jit.anim.node: children reconnect after parent attributes updated on its box • 'getfile' outputs proper path on Windows • fix for arbitrary parameter usage • fix for file attribute in inspector and wheel menu • jit.matrix: 'exportimage' works in 64 bit • fixes for running in 64 bit • jit.qt.grab: iSight fixes for Mac Retina machines • jit.window: shared + fsaa fixes • Jitter: no longer requires Java installation • js/sqlite: error reporting improvements • js/sqlite: works with databases on a non-boot disk on Windows • line~: no longer outputs bang when tempo is changed on global transport • mxj: fixed hangs/crashes/running on Mavericks • OpenGL: fix for software renderer on Windows • parameters window: fixed crashing when clicking on items and sorting columns • pattrstorage: fixed memory leak when interpolating presets • preset: fix for setting a preset using shift+click • live.thisdevice: 'setwidth' triggers correctly when device is in a rack • startup: fixed crash restoring a prefs file on launch • vst~: fixed hostsync inside Max For Live • vst~: generic editor UI updates with messages to object

    • Dec 12 2013 | 2:44 am
      thank you cycling team for fixing pattrstorage bug!
    • Dec 12 2013 | 3:40 pm
      What does "generic editor UI updates with messages to object" mean?
    • Dec 12 2013 | 4:46 pm
      When sending a param change message to vst~ while the plug-in's generic editor window was open, the UI would not update. This has been fixed.
    • Dec 13 2013 | 11:24 am
      thanks for the update! I immediately check the jit.qt.grab and it works BUT the settings message does not open (both 32 and 64) and I get error message: "jit.qt.grab does not understand settings"
    • Dec 13 2013 | 5:56 pm
      Currently, 64 bit jit.qt.grab does not support the 'settings' message.
      If you want to use the 'settings' message on Mac OS 10.9+ 32 bit, you have to send a special message to Max. This must be done before any Jitter objects are instantiated, so open Max from clicking on the application icon.
      1. restart Max 2. new patcher 3. new message box with "; jit usealtgrab 0" 4. lock patcher and click message box
      The 'settings' message should now work to jit.qt.grab.
      You can place a text file in the Max 6.1/Cycling '74/init folder with the text "jit usealtgrab 0;" to ensure that 32-bit Max always uses the QuickTime version of jit.qt.grab if you need those features.
      Please note that if you update to 10.9, QTKit is on by default, and new laptops with 10.9 pre-installed (and some with 10.8) don't provide QuickTime drivers for the built-in iSight.
      Sorry for the inconvenience!
    • Dec 16 2013 | 8:31 am
      Hi Ben,
      placing the text explained above in the init folder doesn't ... init.
    • Dec 16 2013 | 7:02 pm
      @TEP: Sorry, it is probably best to place the file in the Max 6.1/Cycling '74/jitter-init/ folder. Let me know how this goes for you.
      This may in fact not work either, so it may have to wait for the next update to have a way to work around this issue.
    • Dec 17 2013 | 6:22 am
      Did anyone else run into an issue where Max completely stopped working for them with version 6.1.5 on Win7? After I upgraded my work machine copy of Max from 6.1.4 to 6.1.5, Max no longer opened*. It didn’t come back with 6.1.6, and downgrading to 6.0.8 did not work either. The newest still-downloadable version that runs for me is 5.1.
      I went through Cycling74 tech support, but they said (after a lot of trial and error) that my only remaining options are to reinstall the operating system or run a system restore. That still won't give me a way to avoid the same problem happening again in the future.
      *: There was a period of half a day where 6.1.5 was able to open after Cycling74 tech support had me install Pace iLok support. I do not use an iLok, but for some reason this act allowed Max to run for a brief time.
    • Dec 17 2013 | 5:08 pm
      @TEP, re: jit.grab 'settings', lets try again.
      I think you can include this “; jit usealtgrab 0″ message in a file named "jitter-config.txt", located anywhere in the search path and they will be executed when Jitter loads.
      Thanks, -Ben
    • Dec 23 2013 | 9:03 pm
      Built-in iSight is still an issue for me on OS X 10.8 and latest Macbook Air in 32-bit mode.
    • Dec 23 2013 | 10:20 pm
      @nathaniel.stern for OS 10.8 machines with similar issues, you should be able to do the converse as Ben's advice for using the new QTKit grabber alternative. i.e. include “; jit usealtgrab 1″ message in a file named “jitter-config.txt”, located anywhere in the search path and it will be executed when Jitter loads.
    • Jan 14 2014 | 6:40 pm
      I just submitted a bug but I wanted to mention my problem here in case anybody else has it too:
      The new QTKit grabber produces visual artifacts (MAX 6.1.6 running in 32bit mode, Mac OS Mavericks). It also crashes MAX sometimes, especially while changing vdevices or dims.
      I see intermittent visual corruption in most of my existing patches when using the new default QTKit mode in jit.grab. If I restart MAX using the old grabber (via “; jit usealtgrab 0″ message in jitter-config.txt) then everything works perfectly. (I've tried the iSight cam in my older MacBook Pro and a PS3Eye via macam drivers. Same behavior on both.)
      When I include the same jitter-config.txt file in the app script while exporting a standalone, it still uses the QTKit grabber so the image is corrupt.
      Is there a way to make sure that standalones use the legacy grabber?
      Here's a patch to reproduce the problem:
    • Feb 11 2014 | 1:02 pm
      There is still a problem with textbutton object causing a crash, when it receives a value that changes its state in toggle mode, on windows 7.
    • Feb 21 2014 | 4:02 am
      To follow-up on my image corruption problem with the new grabber: I submited a bug report in January and Cycling said they're working on it. Still waiting for a fix. Til then I guess we should use the old grabber if we plan on sending dim or vdevice messages to jit.grab. Bummer.
    • Mar 11 2014 | 7:23 pm
      I found specific system bug. I use "Symbolic Links" & "Hard Links" for save disk space & place links to my files in system directories. Tool at BUT when i put "Symbolic Link" to my subpatch.maxpat from disk D: in "C:\Program Files\Cycling '74\Max 6.1\patches" - during next start MAX is crash.
      MSI GT60-2OD-i7-4770MQ - Nvidia GTX 780M/4Gb RAM-32GB - SSD+2xHybridHDD Seagate-Momentus-7200RPM-Hybrid-ST750LX003 Windows7HP x64
    • Mar 16 2014 | 11:21 pm
      How can I update my Max/MSP to the newest version without registration problems?
    • Mar 18 2014 | 8:15 am
      For updates from 6.x just install the newest version of max. for upgrades from earlier versions you'll need an upgrade license. j
    • Apr 03 2014 | 6:17 pm
      Anyone else having trouble with the Max 6.1.6 installer hanging? I'm trying to upgrade Max 6 on a Mac OS X 10.6.8 system. I've tried to run the latest Max installer a couple times, and it always ends like this:
      Registering updated components...
      Install time remaining: About a minute.
      (see screenshot)
      UPDATE: I think it was hanging on a dialog box about installing some PACE (iLok) extensions, that was hidden behind all the other windows or something.