MAX 6 - weird screen refresh bug

    Nov 06 2011 | 1:50 pm
    i tested max 6 and came upon a weird problem. after searching the forum i couldn't find another thread pointing to this issue, so i wonder if it's related to my computer specifically:
    when running max 6 for a while, at some point the user interface stops being refreshed.
    eg. for msp based patches clicking ui elements produces change in sound, but the element is not updated. simple examples would be a gain number box or a volume gain slider. when locking or unlocking the patch, the corresponding ui element gets updated.
    i can't seem to find out what the reason for this is. my machine is a MacBookPro3,1 2,2 ghz, running mac os x 10.6.8 i also got max 5.1.8 and max 4.6.3 installed.
    anyone had the same experience?

    • Nov 07 2011 | 9:47 pm
      same here
      MBP 2.2 i7 osx10.6.8
    • Nov 09 2011 | 1:26 pm
      i just updated to max 6.0.1 - and bam! happened again (after only 2 minutes of usage).
    • Nov 12 2011 | 1:52 pm
      I'm finding the same
      Windows 7 ultimate 64
      i7 950 3Ghz
    • Nov 12 2011 | 8:48 pm
      Max 6, on Os X Lion... I've the same.
    • Nov 13 2011 | 7:39 pm
      Yes, I'm getting this exact problem but I think it's due to very large, rapid spikes in CPU usage. When I start my live performance patch in Max 6, it runs at about 30% (which is where it stays in Max 5). As I introduce more audio elements, it climbs to about 48%. Then it starts spiking so quickly that the readout still says 48% but I can see the CPU bar jumping up and down really quickly. Around this time, some of the numbers boxes in my UI start to freeze up and then the audio often starts to glitch out.
      ...running Max 6.0.1 on OS X 10.6.8 with 3.06GHz CPU and 4BG.
      ...wondering if using the mixer for parallel processing or getting a RAM upgrade might help?
    • Nov 14 2011 | 9:44 pm
      Hi guys,
      Engineering is currently investigating these reports of CPU spiking. We'll let you know what we find.
    • Nov 23 2011 | 9:37 pm
      Exact problem here. After 3-4 minutes Max6 is really unusable. With the attached patcher, I also receive a lot of crash, simply moving parameters… It seems related to poly~. Also attached a snapshot of the cpu just after launching Max. Cpu overload is visible and it happens every time I launch the software. I wonder if this issue is quite rare, not being a major topic… In my case, after a few minutes it makes Max unusable.
      iMac, Intel Core 2 Duo 3,06 GHz 4 GB osx 10.6.8 Max6 6.0.1
    • Nov 25 2011 | 10:56 pm
      same here.. MBP 2011 15" i7 2.2 quad with 10.7.2
      After a few minutes patches become unusable, and the problem consistently happens when playing with the audio driver settings in max (engine on/off, buffer sizes, etc. cause the screen to freeze, even on very small patches with just a cycle~ 440 and a live.meter)
    • Nov 26 2011 | 5:39 pm
      I've also got that weird refreshing issue but for now it's only in my bpatchers. I use a horizontal livegain~ which only updates when you change the level again.
      BTW why is the shortcut for routing patch cords gone?! Bad move :-(
    • Nov 28 2011 | 7:31 pm
      Any news from the Cycling crew about this issue? Sorry to rush you but Max6 is unusable, at least in my case.
      Thank you.
    • Nov 28 2011 | 8:35 pm
      Mr Matpe,
      I am missing a file called ale_conv1 in your patches.
      Danny, I think has already been in touch with support. We are finding it really hard to reproduce any of this. If you have a guaranteed way to make the Max UI freeze up, please email us in support with full details We need to find out what you guys all have in common.
      Let us know
    • Nov 28 2011 | 10:05 pm
      Uups, sorry…
    • Nov 28 2011 | 10:35 pm
      Hi Andrew,
      some more infos, I hope. This bug seems related to opening different audio patches with audio on, at least in my case. I made this very simple test: - new patcher - create a cycle~ object, open the help file and turn on the audio - create another audio object, e.g. pong~, open the help and turn on the audio… immediately Max gui freezes. If I don't open patchers involving audio, everything seems ok.
      I hope this helps.
    • Nov 29 2011 | 11:13 am
      i can't reproduce it now, as the max 6 demo on both my computers has expired, and i didn't purchase it yet (because of this bug, which renders max unusable for me).
      last time i checked i could easily reproduce it this way:
      open a new patch put a new gen~ object there open help for gen~ turn audio on switch to different subpatcher / tab in gen~ help while audio is on turn audio off / on
      that way i had the same result happening every time i tested. can't check for details now, since i can't run max 6 now.
    • Nov 29 2011 | 5:50 pm
      I have some news, at least relating to my setup…
      After some test, eventually I selected audio built-in instead of my Fireface uc. I closed and reopened Max6 and the issue, with audio built-in, disappeared. I selected again the driver of my interface and no more issue (until now). Could you check and confirm it?
    • Nov 29 2011 | 9:49 pm
      I'd been wondering if this might have anything to with external soundcards, seeing as no obvious solution was presenting itself in terms of patching, computer specs or operating systems. I'm using a MOTU Ultralite. I'd try my patch using the built-in audio, to see if that removed the spiking but my trial has expired too.
    • Nov 30 2011 | 10:46 am
      on my 2 machines i had the bug appear with built in audio, as well as external soundcard. i definitely tried a edirol fa-66, but use a motu 828 mk1 as well, but don't remember if i tried it with max 6.
      i also have to add that at some point after leaving max 6 open when the bug happened, and using the browser, the behaviour went back to normal when i returned to max 6. after that, it happened again though. it's way too confusing to pin it down to a certain action i have the feeling.
    • Dec 11 2011 | 3:49 pm
      @ vogt
      I noticed the same thing, if I stopped using max for a bit, when I came back it would work as normal. I also noticed locking and unlocking my patch refreshed the screen, but that was it. It must have something to do with the cpu spikes, as mentioned above, because the same patch I have been using, after I cut down on the cpu, works without flaw. The cpu before, however was only at 50% but would spike up to 60 or 70. This doesn't happen with the same patch in max 5 so I wouldn't know where to look.
      If I had unlimited time it would be easy to show the max crew what's going on with my (our) machines, but I don't have much time, especially not to make a patch with a lot of cpu usage just to show that there are random cpu spikes and that they suck. Has the Max crew not seen this phenomena yet? Maybe they know too well how to patch and avoid any sort of cpu black holes. However, it's an extremely hampering bug and kills the usability of a patch.
    • Dec 11 2011 | 6:10 pm
      We still haven't reproduced this. We're happy to keep trying, but so far the reports are all over the map. Some people have it with hardly any patching, others only with huge patchers.
      If you think you have a way to reproduce, and it does the same thing on other computers, please let us know about it.
    • Dec 13 2011 | 5:34 am
      I think part of the problem at this stage is that a lot of people who were having this problem can no longer access Max 6 for additional testing. My trial expired quite a while ago. But I'll provide whatever info you think might be relevant and even send my patch, if you think it'll help (though I'd rather not post it here).
    • Dec 13 2011 | 6:42 pm
      If you have an expired demo, but are sure that you have a reproducible way of getting this to happen, please get in touch with support.
      We cannot fix what we cannot see - and so far this problem is machine specific. Noone at c74 has ever seen this problem!
      If you have some time to make a movie, or show us what your system is doing while the UI hangs, or do some screen sharing with a c74 tech, we'd be extremely appreciative - please get in touch.
    • Dec 14 2011 | 4:49 pm
      It happened that I experience the same problem. The system specs are:
      System Version: Mac OS X 10.6.8 Model Name: MacBook Pro Model Identifier: MacBookPro4,1 Processor Name: Intel Core 2 Duo Processor Speed: 2.5 GHz Number Of Processors: 1 Total Number Of Cores: 2 L2 Cache: 6 MB Memory: 2 GB Bus Speed: 800 MHz
      I'm using the internal sound card and can reproduce the problem the following way:
      Open Max 6, open the patch using the dac~ or ezdac~ object, turn on ezdac~ or send startwindow message, stop audio processing by either pressing ezdac~ or sending stop message to dac~, then ezdac~ hangs and still lit, pressing it again hangs the user interface while moving the sliders and number boxes produces output no user interface changes. The same thing sending startwindow message to dac~ object again. The problem started to appear when I installed Max 5 for use with Max for Live.
    • Dec 14 2011 | 5:15 pm
      I've solved this problem using the Matteo method. Changing driver in Audio Status have solved this problem yet I'm using ad_portaudio Core Audio instead of regular built-in option which brings this problem again when you select the built-in in driver menu.
    • Feb 13 2012 | 1:42 pm
      Hi, i have the same problem described here. My configuration is 10.6.8 and Max 6.0.3. I have also Max/Msp 5.1.9, Motu Ultralite MK3 or Echo Audio Fire 4. This is referred only to Max 6. I have captured a video screening to show the GUI Freezing Bug. There is no sound captured but i can ensure that is working perfectly. The only problem is the GUI. It seems to have a kind of lag in the response, but if you press the ezdac button it starts again to freeze. The mouse also disappear when moving sliders, numbers and so on and there is no change in the interface. This is the video as an unlisted link on youtube.
      Is there anybody else having this annoying bug? Cheers
    • Feb 13 2012 | 1:49 pm
      Is there anything to do with "Parallel Processing"?
    • Feb 13 2012 | 2:09 pm
      Hello, each time i use max6 for audio, i can reproduce this very annoying bug. In each msp patch (no matter how big it is) when i turn off and on the ezdac~ ui object, Ui feedback doesn't work at all, or is delayed.
      If i just create a new patcher, and add a cycle~ -> gain~ -> ezdac~ -> meter~
      as soon as i turn off audio clicking on ezdac~, meter~ get frozen and, even if i can hear changes in sound, i can't see any changes on ui.
      overdrive & audio interrupt not activated internal sound card MBP 2.3 GHZ quad core. OSX 10.6.8
    • Feb 13 2012 | 8:19 pm
      i used the demo now for 2 weeks, everything worked fine since yesterday. at some point the ui freezes, means i scroll a numberbox, sound is changing but display stays the same. the only way to update is to unlock the patch, but as soon as i lock it again same behaviour?? no solutions yet?
      osx10.7.3 Macbook Pro, i7 /2,5 ghz quad 8 gb ram (1333mhz)DDR3 max 6.0.3
      maybe it`s 10.7.3 related as i updated the day before yesterday? its a brand new machine and it happens that i was too stupid to already began with backups, so theres no way back to 10.7.2
    • Feb 13 2012 | 8:20 pm
      now even the unlock trick don`t works anymore. same after restart and reboot AND: it isnt patch related, its in every patch
    • Feb 13 2012 | 8:43 pm
      HI Guys,
      I'm sorry that you are experiencing trouble. These reports could be the same, or different issues. Max 6.04 will be out in a couple of days. Please try that, and if you're still in trouble then I'd like to invite you all back into support so we can get to the bottom of it individually.
    • Feb 14 2012 | 9:58 am
      If i turn the audio driver to portaudio_coreaudio it works perfectly.
    • Feb 15 2012 | 10:46 pm
      solved with max 6.04 !!! thanks !
    • May 03 2012 | 8:20 pm
      Ohhh Help! I am having the same problem... After a while of working on my patch, the screen freezes!!! Even though the video keeps on running at a decent frame rate, but I cannot do any changes on the patch. I have a really important performance on Wednesday and I just don't know what to do....!
      I have an iMac 3,4 GHz Core i7 8 gb ram (1333mhz)DDR3
      I am running Max 5.1.9 because there's some compiled objects that don't work yet in Max 6. And Off-course the buggy Lion version 10.7.3
      Is there's anyone there that could give me a clue on how to solve this problem?
      Thanks a lot!!