Max 7.3.4 Released

    May 30 2017 | 6:31 pm
    We are happy to announce the release of Max 7.3.4. There are over 50+ bug fixes in this release, with a focus on VIDDLL and Jitter improvements, as well as shipping with a BEAP Package update.
    Please take a look at the change log below, and as always, you can download the installers here:
    Enjoy! -Ben
    Fixed Bugs: • attrui / nslider / tab: fixed memory leak • BEAP: miscellaneous fixes • Debugging: fixed error when patch cord is disabled • Export amxd from Project: device appropriately frozen • fpic: no longer grows when force aspect is on • Install: Max starts normally on other user accounts (Windows) • jit.anim.path: no longer crashes on 'next' message • / fix for strange behavior with capture @cull_mode 2 to • finds model file in Project when using @file attr in object box • / : mat_diffuse is appropriately applied to all instances • fixed crash when second argument is > 10 • fixed drawing with certain rotatexyz values • fixed capture output when sent directly to syphon • fix recursion crashes due to user error when setting layer and child attributes • fixed issues with only setting a @min param • fixed crash when changing subdiv attribute • fixed errors when processing texture from capturing • misc bug fixes • jit.grab: fixed clear message • fixed unique behavior with still images • no longer outputs after 'dispose' and @unique is set to 1 • restarts after stop when rate is set to -1 • fixed usage in Max For Live • jit.phys: fixed crash when filter count arg exceeds 10 • jit.playlist AVF engine: fixed playback when playing clip slot that is not looped • jit.pwindow / OpenGL: fixes for rendering in Max For Live if certain vst plugs are loaded • jit.pwindow: fixed use in bpatcher • jit.record: fixed migaligned planes for certain dims • jit.rubix: fix crash with 64 bit and fix all warnings • Jitter OpenGL: fixed invisible GL contexts in windows • Jitter OpenGL: fixed 'turn' message errors • Jitter: fix for software rendering with matrix context on Windows • live.remote~ / gen~: fixed threading issues that was causing Live UI freezing • Max For Live: fixed issues when clicking 'edit' in device toolbar • maxurl: stability fixes • midiformat: pitch bend input is constrained • mira.frame: added to standalones • miraweb multislider: size attribute is updated in browser when changed with list input • Patching: patch cord color is retained when duplicating more than once • Patching: Fixed crash when deleting patch cord • pattrstorage: improved state recall and subscription list updates • peak / trough: second inlet is hot • playlist~: Fixed file ordering when dragging/dropping a folder • playlist~: Playback properly continues after 'remove' message • qlist: ‘fwd’ message with arg no longer freezes Max • qlist: ‘set’ message appropriately uses arguments • seq: fixed crash when reading saved text file • Standalones: improvements for signing issues • VIDDLL engine: fixes for memory leaks, a rework of 'File Open' functionality & misc other updates • VIDDLL: Can now play pcm audio files • VIDDLL: Fixed crash when audio-only files are loaded • VIDDLL: Fixed photo-jpeg output_texture  • VIDDLL: Improved support for prores codecs • vst~ / character encoding: fixed charset issues when reloading Max patchers with VST snapshots

    • May 30 2017 | 8:07 pm
      That looks like a ton of work. Thanks for all improvements!
    • May 30 2017 | 8:20 pm
      too bad this url's link is not sharable·3·4-released/
    • May 30 2017 | 8:23 pm
      Hi Julien,
      What do you mean? Most browsers should handle the dots. Does this work for your needs?
    • May 30 2017 | 8:23 pm
      twitter denied it. but that's absolutely not important, sorry.
    • May 30 2017 | 8:24 pm
      Actually, that's good to know! I'll pass this along to our web team.
    • May 30 2017 | 9:11 pm
      @josh celli - Yes, replace unless you'd like to keep the old version around. In which case they can both co-exist.
    • May 31 2017 | 2:21 am
      erhm, the download link brings me to this black page :
    • May 31 2017 | 2:23 am
      now it's working. I can only suppose it was beeing worked on at the time i wrote this :)
    • May 31 2017 | 9:22 am
      I think, judging from my experience (the link kept taking me to the previous version's d/l page), that you're right. The announcement preceded the action!
    • May 31 2017 | 4:56 pm
      wow, new viddll and hap engine in the same day. what's new with the hap engine?
      I was actually experiencing choppiness during a videos first loop thorugh (although after a loop everything seemed to be smoother) with viddll 1.0.9 (but not in 1.0.7) driving frames ([metro]> [counter]>[prepend frame]) with h264 video, but it's smooth again in 1.1.0. This is without messing with the cache_size or loadram settings.
    • May 31 2017 | 6:01 pm
      great to hear greg.
      Hap update is just for compatibility with 7.3.4, no new features.
    • Jun 01 2017 | 8:55 am
      Yeah, this is really solid update, thanks!
    • Jun 02 2017 | 6:37 am
      impressive update, well done guys!
    • Jun 06 2017 | 11:17 pm
      Good update! Nice job!
    • Jun 08 2017 | 11:20 pm
      Hey folks, we discovered an issue in this latest release with playback crashing when using the viddll engine, and have updated the installers with a fix.
      If you are a viddll user (i.e. anyone using on Windows), I strongly recommend you re-download the 7.3.4 installer to get this update.
      Apologies for any inconvenience.
    • Jun 10 2017 | 11:14 am
      Hi Rob Thanks for the update. I noticed that the new installer file (at least for Mac) has the same date as part of the file name as the old one. (Max734_170530.dmg). Does it also have the same build ID in the about Max dialog? What would be the best way to distinguish the 2 versions of Max 7.3.4? (I am asking this because I may have to identify the installed version on some students computers the next week) .
    • Jun 11 2017 | 11:00 pm
      The build number may have changed. I'm seeing `de5a74a` in this build under About Max. (32-bit mac)
    • Jun 12 2017 | 4:04 pm
      yes, de5a74a is the correct updated version.
    • Jun 12 2017 | 4:59 pm
      @ROB: Thanks!!!!
    • Jun 18 2017 | 12:51 am
      Unfortunately no seamless loop @Viddll with h.264 files (win and mac). It stutteres at the end of the file. I'm pretty sure this was OK with viddll 1.0.9
    • Jun 20 2017 | 1:01 pm
      I am not sure if it's the latest Max thing as I've just got a computer with Sierra 10.12.3 and I haven't tried older versions of Max on that system but saving patches is very buggy:
      - usually it saves in wrong folder not the one that you specify (can't figure out how it chooses the folders)
      - sometimes it doesn't save at all (it saves but then there is no file or at least search in finder can not locate it)
      - even if you try only to "save" it always do the "save as"
    • Jun 20 2017 | 1:14 pm
      PS: I've managed to find the missing files, they were in ...C74/interfaces, that's why finder could not locate them.
      So I guess the main problem is in "random" folder selection by Max, it simply ignores the folder you choose. But not always, most of the time.
    • Jun 20 2017 | 1:18 pm
      ...and please suggest some workaround if there is any until the bug is fixed as this is really annoying.
    • Jun 20 2017 | 3:55 pm
      @T sorry this is not reproducible.
      Please send details of your issues to technical support.
    • Jun 20 2017 | 6:03 pm
      Hi Andrew,
      here is the video that demonstrates my problem:
      As you can see as I save the patch in specific folder, the file gets saved but does not land in that folder. Then as I try to reopen it from the "open recent" it also does not want to open. Once I locate the file on my disk (that is not on the video), which is usually in some folder I was working in recently, and then move it manually in the correct folder, the "open recent" starts to work. However sometimes files end up in weird locations such as C74/interfaces.
      As I said that is not happening all the time and I need to be a bit persistent to reproduce the problem. But essentially what you need to do is a bit of save and save as and eventually you get there:)
    • Jun 20 2017 | 8:16 pm
      One of the folders in the path to the directory you are trying to save to has a "/" character in its name. For various reasons, mostly to do with cross platform compatibility, this is not supported in Max. Sorry about that.
      Let us know if you are still having issues
    • Jun 21 2017 | 10:00 am
      Thank you Andrew for explaining that.
      I guess the problem is/was that saving in folders with "/" sometimes works and sometimes not. If you try to do what I did on the video the saving will work but then at some point it will stop working....and maybe it will start working again. And that is confusing for the users because the behaviour is essentially buggy.
      And that is in general my biggest problem with Max - I never know if I encounter a bug or am I doing something wrong as the things often "semi work". Especially when one works with point clouds in Jitter as I do. I am coming across these "semi work/buggy/nowhere documented" surprises literally constantly. And what is the most surprising for me is that I don't have a feeling that there is a wish from C74 side to fix these things. New versions are coming up but the old problems are still there...
    • Jun 21 2017 | 2:36 pm
      Sorry you feel frustrated. We're always happy to get detailed reports of trouble. If we know exactly what the issue is, then maybe we can help fix it or workaround.
    • Jun 23 2017 | 8:25 am
      Hi Andrew,
      here is one detailed report of trouble (although I am not really sure if it is 7.3.4 related).
      I am trying to update an old patch (I want to play mp3/m4a files in addition to linear files) that uses sfplay~ and the sfinfo~ file length to normalize my own playbar display. sfinfo~ sadly will NOT load or preload mp3/m4a files (just try with the help file). Using preload with linear files also gives no info about the file, you have to "open" it, which makes preload a bit less handy.
      The same mp3/m4a issues are with sflist~, they just won´t load.
      So finally I decided to rewrite everything, using a named sfplay~with "open", "seek" and "get named" for sfinfo~. Now a real showstopping inconsistency/bug within sfplay~shows up:
      When retriggering the same linear file while it is playing, the "bang-when-done" outlet is not firing (as it was always before).
      When retriggering the same mp3/m4a file while it is playing, the "bang-when-done" outlet is firing, which makes it impossible to use it consistently when file types are changing.
      I am stuck now..., and am I really the only one with this problem?!
      And no, I won´t use buffer based playback.
      This all happens on WIN10 and Mac El Capitan, and btw. , the file name in sfinfo~WIN32 always has a .aif ending after the .mp3 ending (m4a is not recognized).
      A testpatch is attached.
    • Jun 23 2017 | 9:34 pm
      Please send this one in to support. If there has been a regression it can get sorted out.
    • Jul 08 2017 | 9:21 pm
      I repeated tried to download the update (7.3.4). At first I assumed it was the result of a "less-than-professional quality" Internet connection. However, I just used my University's high-speed and stable Internet connection... and ... it took three times before it downloaded successfully. Yikes!
    • Aug 17 2017 | 5:32 pm
      For some reason, every time i launch Max, i need to give it my password.
    • Aug 17 2017 | 7:13 pm
      ....and it stopped asking me for the password. I dont know why, but it asked me at least 3 times. Thanks anyway for support!
    • Aug 19 2017 | 9:45 am
      Ok now its asking for it again.
    • Aug 28 2017 | 9:02 pm
      Anyone else getting "the feature you are trying to use in on a network resource that is unavailable" message on installation. It appears to be looking for a different .msi file than what exists?
    • Sep 19 2017 | 9:02 pm
      I installed the new version. Now when I create a new object and start typing the name I don't get all the available options in the menu that appears below the object. This happens for the most obvious objects. Like when I start typing in "gain~" it suggests jit.glop and live.gain~ but not gain~. When I type in "counter" it suggests bach.counter ( maybe from a library i installed) and when I type in "scale" I get a lot of objects with scale~ at the top of the list, but not a "scale" object.
      Did I miss something in installation? Let me know what you think. thanks.
    • Sep 27 2017 | 9:37 pm
      Hi, I'm just giving my last post a bump since no one responded. This problem is still persisting.
      Here was my original post:
      I installed the new version. Now when I create a new object and start typing the name I don't get all the available options in the menu that appears below the object. This happens for the most obvious objects. Like when I start typing in "gain~" it suggests jit.glop and live.gain~ but not gain~. When I type in "counter" it suggests bach.counter ( maybe from a library i installed) and when I type in "scale" I get a lot of objects with scale~ at the top of the list, but not a "scale" object.
      Did I miss something in installation? Let me know what you think. thanks.
    • Sep 27 2017 | 9:44 pm
      @NICNUT, I recommend contacting support to get sorted, but you can start by quitting Max and trashing Max's preferences, which are stored here:
      Mac: ~/Library/Application Support/Cycling '74/Max 7
      Win: ~/AppData/Roaming/Cycling '74/Max 7 -Ben
    • Sep 27 2017 | 10:27 pm
      I'm on a Mac. I didn't see any Cycling 74 folder in the Application Support folder. I think I might have trashed it a while ago due to another issue I was having. Should I create one? Or is there a folder that's supposed to be there?
      thanks, nick
    • Sep 27 2017 | 10:43 pm
      Hi Nick,
      If you don't have a Cycling '74 folder there, that means that something far more unconventional is going on. Please drop a note to support at cycling 74 dot com and they will help you resolve the issue.
    • Sep 28 2017 | 1:05 pm
      @BenBracken Ok will do thanks.
    • Oct 01 2017 | 1:24 pm
      Hi all I cannot import ANY file from outside Max 7 into Max, such as audio/image/video files not even on the dropfile object. Looks as if there is some general setting which does not allow me to move any file into Max windows. Plus I keap experiencing crashes when opening jit.normalize help file. win 10 pro. thnx
    • Oct 01 2017 | 1:29 pm
      so just to add some info it is the demovideo file which makes any help file which features this handy patcher crash Max
    • Oct 02 2017 | 2:56 pm
      @PHANTASMEANSNO it sounds like something is wrong with Jitter / your video engine. Please email support at cycling 74 dot com and they will get you sorted.
    • Oct 03 2017 | 9:08 am
      Hi Ben, thnx , will do. just an update, executing Max with administrator privileges on win 10 pro does not allow one to load files directly from the file system (apparently it is an issue othrs have encountered). will contact support for the crashes related to videodemo
    • Aug 28 2018 | 3:07 am
      Hi all why "fiddle~" and "bonk~" give error and does not work using Max 7.3.5 in my Mac as I already forced Max into opening 32 bit mode to run the these externals but still does not work. any idea from anyone? thanks all
    • Nov 30 2020 | 9:43 am
      Hi. I update my mac to "Big sur" then max7.3.6 doesn't work. The application can open but when I try to open a patch it crash down. Does anyone have an idea to fix it please? Thank you
    • Nov 30 2020 | 10:15 am
      downgrade the OS
    • Nov 30 2020 | 10:31 am
      ? 32bit objects In your patch?
    • Dec 02 2020 | 4:02 pm
      Thank you both for replying. I didn't put any 32bit object but it didn't work. I asked to cycling74 then they told me that they will not upgrade Max7 so I need to downgrade the OS. (or upgrade to Max8) It's time to upgrade. Thank you again.