Max 8.1.5 Released

    Jun 16 2020 | 5:05 pm
    We are happy to announce the release of Max 8.1.5.
    This release focuses on issues introduced with Max 8.1.4, specifically addressing startup times on Mac, Parameter and Jitter regressions, and the inclusion of the new Javascript extensions (jsmaxobjlistener, jsparameterlistener, jsparaminfoprovider) in the Windows installer. We've also included a minor update to BEAP, among a few other things. Please take a look at the list below for more info.
    As always, you can download the update here:
    Enjoy! Ben & Cycling '74
    Fixed Bugs: • BEAP: Bugfix update to v1.0.3 (see for changes) • install: improved Mac startup time (don't check validity on externals in Max's resources folder) • fixed read message • jit.grab (AVF): fixed crash when device removed and getformatlist queried • jit.playlist: fixed issues when reloading patches with texture output and implicit drawto • maintain connection to matrix only object on patcher load • Jitter: setting attributes with attrui does not crash • jsmaxobjlistener, jsparameterlistener, jsparaminfoprovider: added to Windows installer • jsparaminfoprovider: improve getinfo dictionary • live.banks: add/remove buttons work • Parameter: ensure dictionary ordering in patcher JSON • Parameter: fixed undo issues with stored only pattr objects • Patcher Windows popup in Toolbar: fixed crash when selecting some patchers • Patcher: transparent notitle windows work even when enabletransparentbgwithtitlebar is off • pattrstorage: ensure savemode respected when object is freed • Snapshots: fixed restore issues with some patches • VIDDLL fixed non-HAP texture alpha channel usage

    • Jun 16 2020 | 10:40 pm
      Thanks C74!
    • Jun 17 2020 | 4:26 am
      • VIDDLL fixed non-HAP texture alpha channel usage >>> thanks!!!
    • Jun 17 2020 | 8:58 pm
      Thanks for this update, I started playing with Vsynth and Vizzie a couple weeks ago, 8.1.4 broke a lot of the patches I had saved, but with this update stuff is loading like I remember them looking like.
    • Jun 27 2020 | 4:35 am
      I'm getting a weird bug involving scripting an instance of [vst~] and trying to load a specific plugin, Pianoteq ( This is causing a patch I've been working on for years to suddenly give me error messages: "vst~ midievent: effect doesn't want events." I've tried a few other plugins without being able to generalize the problem beyond Pianoteq. Even still, something in this update broke what was functional for several years now.
      I've attached a patch which goes through the problem step-by-step. In order to replicate, you'd need at least a demo copy of Pianoteq. Would anyone be willing to test this on their system and see if you're able to confirm the presence of the error message when scripting a new instance of Pianoteq loaded in [vst~]?
      Please see attached patch.
      Side note: It would be useful to have a link to Max 8.1.4 to downgrade. Can anyone point me to that?
      Thanks for your help!!
    • Jun 27 2020 | 9:18 am
      max versions are hosted on just add the version number
    • Jun 28 2020 | 2:07 am
      Thank you Source Audio.
    • Jun 28 2020 | 2:10 am
      Replying to myself (and maybe someone else in the future) regarding Pianoteq errors:
      I was able to solve the problem by specifying the VST version of the plugin. Apparently the problem was isolated to the AU version.
    • Jul 06 2020 | 6:22 pm
      It looks like there might be some unsigned Viddll .dylib files - I've had to disable Gatekeeper to get to work.
    • Jul 06 2020 | 6:57 pm
      @ROBIN All the dylibs are signed (we couldn't pass Notarization without that). What version of VIDDLL do you have installed? Could you send an email to support at cycling 74 dot com with your Support info?
    • Jul 06 2020 | 7:29 pm
      Ah - I've just noticed that the console is reporting I have two versions of jit.viddll.engine.mxo - there was an old one from when it was kept in the packages folder that was amongst some stuff I recently copied over. Sorted!
    • Jul 06 2020 | 7:30 pm
      @ROBIN ahh great to hear, thanks so much for following up!
    • Sep 02 2020 | 2:15 pm
      Hi. I think Max 8.1.5 has broken a few Jitter patches. I'm trying to roll back to 8.1.4 but can only seem to download 8.0.8. Where can I find 8.1.4?
      EDIT: I worked it out through looking at the release dates/syntax of the installer filename. As sometimes things get broken between updates it would be really useful if this was a bit easier!
    • Sep 02 2020 | 2:53 pm
      However, we'd love to know what broke so we can fix it! Feel free to follow up on a new thread or send a report to Support .
    • Sep 08 2020 | 3:51 am
      Above "Mac" and "Win" must be exchanged. I have a trouble to authorize Max8 - "authorization" window is empty, so I am testing with Max8.1.4.