Max 8 rendering consistently slower than Max 7 on Windows?


    Apr 15 2019 | 2:19 pm
    Hi all, Running this test patch on Windows, I find that Max 7 consistently gives me higher FPS (around 27.2) than Max 8 does (around 23.2).
    Can anyone reproduce?
    Max 7 version: 7.3.5 (latest) Max 8 version: 8.0.5 (latest) Windows 10 Pro Processor Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz, 3600 Mhz, 4 Core(s) Graphics card: NVIDIA GeForce GTX 1080

    • Apr 15 2019 | 4:03 pm
      hi Tarik. I can reproduce your findings on windows. oddly enough on Mac Max 8 wins by a few frames.
      In any case, this isn't the optimal way to draw 3000 gridshapes. using jit.gl.multiple instead will give more fps and more fps parity between max 7 and 8.
      additionally, enable displaylist on the gridshape, and if your fps average is tending less than the display refresh, disable vsync.
    • Apr 15 2019 | 5:40 pm
      Hi Rob,
      Thanks for your answer and the helpful tips! In my original patch jit.gl.multiple isn't an option since I do more complex stuff there like attaching different shaders and setting their uniforms to different values etc. As it stands, max 7 runs my original patch significantly faster than max 8. I strongly suspect that also other aspects in Max 7 run faster, but it's complex to pinpoint exactly where the speed gains lie (though I've noticed that especially when memory usage increases, the disparity also increases). So I just chose this clear example as the first issue to tackle, to incrementally get closer to a proper performance on max 8. Obviously I'd prefer to benefit from the max 8 features, but currently the speed issue is so significant that I can't make the jump yet.
    • Apr 15 2019 | 7:04 pm
      Hi Tarik,
      One thing to pay attention to is that patcher rendering of Max 8 under windows is HDPI aware while Max 7 is not. So if you are using a HDPI monitor, the rendering of patchers does take up more processing time than under Max 7 to handle the greater number of pixels being rendered. I'm not sure that this is where the bottle neck lies, and we can do some more profiling with your example to better clarify any discrepancies, but in the meantime, you can test this factor by turning off HDPI rendering in the Max preferences and see if it has an effect for your purposes (note that on Mac this is done via Finder->Get Info->Open in Low resolution rather than preferences).
    • Apr 15 2019 | 8:43 pm
      Thanks Joshua, Nice hunch, though unfortunately that didn't do the trick...
    • Apr 20 2019 | 4:30 am
      hey Tarik we've identified a few areas to investigate that may yield some speed improvements with the overhead involved in non-automatic drawing. Won't have a chance to dig deeper until after expo.