Max crashes when turning audio on from this patch

    Dec 05 2012 | 1:19 pm
    Hello everybody,
    I put up this simple patch for experimentig with granulation. But I'm stuck in this weird behaviour.
    When I click on the ezdac~ to turn audio on, Max crashes. I tried to turn audio on from the "Audio status" window and still it crashes. I also tried to open another patch and turn audio on from there and it crashed again. Now the strange thing: the only way to avoid crashing is: open a working patch, turn audio on, then close the patch and open the "bad" patch that I'm posting below. Max opens it, it "stops thinking" for two or three seconds before drawing connections and then the patch is open and working. Then, if I turn audio off and on again, Max crashes.
    and here's the poly~ patcher (save it as freezer2.maxpat)
    Pleas note: - I've never had stability issues with Max before. I usually run more complex patches for several hours without crashes or strange behaviours, so I guess it may be something related to this patch, or a very esoteric bug. - The problem seems not related to CPU load, AFAICS, for I tried to reduce the voices number to the poly~ to 1 and still crashed.
    Some info about my system: Macbook Pro 2009 2.66 GHz Intel Core 2 Duo, 8GB Ram, Mac OSX 10.6.8., Max 6.08

    • Dec 05 2012 | 2:06 pm
      It's either crashing, in my case, or takes a while for audio to start (on a little older unibody). When I reduce the size of the delay~ to one second instead of a thousand, then it works fine. Maybe long delays are better implemented using tapin/out, however, in your case seem not very necessary.
    • Dec 05 2012 | 2:25 pm
      Sure, I was experimenting with parameters and trying to push things to limits, and I completely forgot about magnitude orders! I too think that a 1000 secs. delay is not necessary at all... thank you for pointing out the issue!
      I reduced to a much more reasonable 10 seconds value (Maybe it's still too big for my needs, but just to see what happens) and everything is fine now!