Max for Live device doesn't output MIDI when open in edit mode


    Aug 23 2015 | 6:18 am
    Seems to be an issue only since upgrading to Max 7, I always used to be able to output MIDI from Max for Live devices while editing them, is there some setting that I'm missing here? Exact same patch outputs MIDI notes fine when not in edit mode.
    Thanks

    • Aug 26 2015 | 11:03 am
      I get the same problem intermittently. Sometimes saving the device helps.
    • Sep 03 2015 | 8:38 pm
      Same issue here
    • Sep 04 2015 | 2:56 pm
      when you're editing a device, the midi and audio outputs come out of Max and not Live. Make sure your Max Midi setup is setup correctly
    • Sep 05 2015 | 12:24 am
      Yeah, i've had this problem too.
      But what does it mean exactly that 'outputs come out of Max and not Live' if you have some kind of Max MIDI effect in Live that is feeding a plugin instrument? Surely when Max is opened from Live, with Live authorisation, it sets its outputs to 'Live' mode automatically no? It's annoying that when you open the device for editing all the notes or whatever are immediately cut off so you can't hear what's happening any longer as you edit the device. Until you hit save at least.
      I'm sure also that this behaviour never used to be the case in previous versions of Max/Live.
    • Sep 05 2015 | 4:25 am
      I've been emailing back and forth with support about this but beyond updating to 7.0.5 and clearing my Max preferences I haven't been offered a solution (the problem persists).
      I have no idea what it means that MIDI goes to Max instead of Live, even when I'm using the dedicated [midiout] object, this behavior is definitely different from previous versions but Max support for some reason can't replicate my problem. By the way saving the device does nothing for me either, I can't get MIDI out from edit mode under any circumstance.
    • Sep 05 2015 | 10:50 am
      Have you tried switching Preview mode on/off?
    • Sep 05 2015 | 2:24 pm
      Preview mode doesn't make a difference for me
    • Sep 05 2015 | 3:57 pm
      I just checked on my system:
      When i open the Max editor it stops passing any MIDI information into Live until i either close the editor (after saving if there have been changes made), or until i switch the 'preview' mode off, thus handing control back to Live. Which is silly since it means i'm not getting a preview at all.
      So basically editing a MIDI effect in Max stops any MIDI getting through to the rest of the Live chain until the Max editor is closed.
      Max still receives MIDI information from Live however, just does NOT pass any MIDI on into Live to preview changes made inside the Max editor.
      I'll try to check the behaviour with Max 6 and see if it is the same.
    • Sep 05 2015 | 4:06 pm
      I believe this is the expected behavior that is explained in the documentation same thing with audio
    • Sep 06 2015 | 12:16 am
      Florent, what part of the documentation covers this?
      When I emailed support they acknowledged that they were not actually experiencing this same behavior and couldn't replicate my problem. They get MIDI output into Live from edit mode.
    • Sep 06 2015 | 9:04 am
      Same problem here... Max 7.05 Live 9.2.2 OSX 10.8.5
    • Sep 06 2015 | 3:10 pm
      I was referring to this but now I see that I'm wrong: https://docs.cycling74.com/max5/vignettes/core/live_limitations.html
      why not having a noteout in your device that you use when editing?
    • Sep 07 2015 | 1:40 am
      I guess this is the relevant part of that page:
      When authorized only via Live, the Max application will not use its own MIDI drivers. MIDI input arrives from Live and MIDI output is sent to Live. MIDI I/O works only when using preview mode. If you turn preview mode off, all MIDI I/O for the Max application will stop.
      My Max is only authorized via Live so what it's saying is that the MIDI should be going into Live from edit mode as it always did before Max 7
      In my case I set up a [send] object that sends my MIDI data to another device that only receives and outputs the MIDI and is not in edit mode, that works but it introduces too much latency to be useful for the current device I'm working on.
    • Sep 07 2015 | 2:40 am
      ah ok, if you only have Live authorized then yes it looks like that's a bug the latency thing sounds like the regular behavior though
    • Sep 07 2015 | 2:44 am
      What do you mean when you say the latency thing sounds like regular behavior? Sending the MIDI data to another device is introducing latency, compared to my device outputting MIDI itself (when not in edit mode). Latency using [send] is to be expected but it's part of the reason why I would like to be able to output MIDI from my edited device, as in previous versions, so my MIDI output can be in sync with Live's grid.
    • Sep 07 2015 | 4:11 am
      Hey, so it seems i'm experiencing the same kind of issue as JDUDEO, with Max being authorised by Live not outputting MIDI correctly.
      One of the big 'features' of the Live 9.2 update was the supposed removal of latency, or at least the correct compensation of it in Live between Live and Max devices. This update also introduced Max 7 into the Live environment.
      When i open a Max device for editing from Live, it cuts off all MIDI output from the device into Live, and seems to have a kind of inverted behviour with the preview button where it is unlit by default when i open the device to edit it, this being when no information is passed to Live. But if i press it, it actually illuminates as if preview were now 'on' and MIDI goes through into Live again, though not via the Max device…
    • Sep 07 2015 | 4:56 am
      @JDUDEO the Max doc (same page) says: "Communication between devices using send and receive is supported, but there may be some latency involved when sending data between devices." so it looks like your delay issue is an expected thing to happen.
    • Sep 07 2015 | 5:00 am
      yes I know that the latency between send and receive is expected to happen, that's the whole reason I would like to have a fix for this problem of MIDI not coming out from edit mode.
    • Sep 07 2015 | 5:01 am
      did you try to get back to the support? they're usually pretty awesome at fixing things
    • Sep 07 2015 | 5:07 am
      I haven't received a response since sending screenshots of my Live and Max MIDI settings but since that was on friday I'm going to give them a business day or two to see what they say.
    • Sep 09 2015 | 3:01 pm
      So I was told by support that this is a bug that occurs when your Max is only authorized for Max for Live and not the full version, hopefully the next update will include a fix.
    • Sep 09 2015 | 5:09 pm
      I think I have this same problem with a M4L and and full Max licenses...
    • Sep 10 2015 | 12:23 pm
      small probably unnecessary datapoint: I do not see this with full Max *and* M4L license.
    • Dec 29 2018 | 8:55 pm
      Wow - I'd be surprised if this bug is still an issue - but I am experiencing this behavior with the device I'm working on. Everything works fine, but then not only stops working when in edit mode, it continues to not work after closing the patch even if I haven't made any changes. I have to delete the device and re-load.
      I own Max 7 and Live 10 but entering edit mode opens Max 8. So - could this be happening because I have not got an authorised version of Max 8?
    • Dec 29 2018 | 10:39 pm
      check out if you can select Max7 in Ableton‘s preferences instead of the bundled version. also I’ve noticed on my machine that editing and closing a M4L midi device without saving it breaks the midi connection. Try cmd+S before closing the device; that works for me all the time.
    • Dec 31 2018 | 4:10 pm
      Cheers - unfortunately I get the error - "Failed to set path - Live requires at least Max 8"
    • Dec 31 2018 | 7:26 pm
      OK - this is REALLY annoying now. Surely it is a fundamental feature for your patch to work when in Edit mode. So either I have to upgrade to Max 8 or build my patches in Live 9? ... Though the latter may may kill 2 birds with one stone actually make the patches more robust as I am finding weird differences with the way Live 9 and 10 handle MIDI.
    • Mar 14 2019 | 12:54 am
      Pechnatunk - did you ever figure out a solution? I am struggling with the same exact problem!