Max for live devices won't open in editor (Max 5.1.9 & Live 8.2.6, OSX Lion)

    Nov 24 2011 | 11:05 am
    Since my upgrade to OSX Lion, I can't open patches in the Max editor anymore... it will get stuck at "Starting Max Editor...". I've installed the latest version for Max as well as Ableton AND trashed the Preferences.cfg of Ableton.
    ALSO, I can't open amxd files in MaxMSP if I want to... Anyone got any idea? I need to do some workshops tomorrow on M4L, anyone got any idea?
    Thanks in advance!

    • Dec 02 2011 | 10:31 am
      Same problem here!
      Ableton Live 8.2.6 M4L (MAX 5.1.9) OSX Lion 10.7
      - Checked the hosts file - Deleted the 'Max 5 Preferences Folder'
      Still the same problem. Starting Max Editor.. . Stuck!
    • Dec 02 2011 | 11:16 am
      Fixed it already.
      Open finder -> menu bar 'Go' -> Select 'Go to Folder' -> Fill in '/etc/' -> The hosts file should be located in that folder -> Open hosts file.
      Now the hosts file should look like this:
      ## # Host Database # # localhost is used to configure the loopback interface # when the system is booting. Do not change this entry. ## localhost broadcasthost ::1 localhost fe80::1%lo0 localhost
    • Dec 02 2011 | 11:22 am
      In Lion you first have to make a duplicate. You can change the name later to 'hosts' and overwrite it. And make sure when you save it in 'TextEdit' deselect the 'If no extension is provided, use ''.txt''.
    • Dec 29 2011 | 2:18 am
      I have the same problem on Snow Leopard and Live 8.2.7, but neither deleting prefs nor changing the hosts file fixes the problem. I had the same problem before I upgraded from Live 8.2.5 to 8.2.7 and from Max 5.1.8 (I think) to 5.1.9, but somehow upgrading seemed to take care of the problem. Now, a couple of days later, the problem is back.
      I've checked both hosts files btw (etc/hosts and private/etc/hosts).
    • Dec 29 2011 | 3:41 pm
      I'm just curious --- why is the hosts file needed? Why is name resolution required to edit a file?
    • Mar 26 2012 | 7:50 pm
      I am having this same issue. I already checked my hosts file(s) and they appear exactly as they should. Tried uninstalling and re-installing everything. Deleting prefs. Ugh. I have to do a Max for Live lecture soon at a festival.
      Emailed support, more or less venting
    • Apr 15 2012 | 4:09 pm
      For me the issue was an old version of Speakerphone which kind of broke a lot of things in Live. Installed the Lion-compatible version and all is well now!
    • Feb 25 2013 | 3:35 am
      The problem is back. New computer (now 10.8) and version 8.3.4 of Live (still version 5.1.9 of Max5). Tried using Max6 for MFL instead, but nothing opens.
      - Thrased pref files for Max5, Max6 and Live - Checked hosts file (etc/hosts and private/etc/hosts) - Repaired disk permissions
    • May 02 2013 | 1:59 pm
      Did you find a solution to this? This might be related...
    • Jun 07 2013 | 4:34 pm
    • Feb 25 2015 | 1:45 pm
      I have the same problem as @SYNNACK, "Max Editor" for editing m4l-devices did not start and Max stay in the foregriund till I quit it. I wrote ableton, still no answer... @ STEVESAVAGE how did you sorted ?
      Setup: OS 10.9.5 / Max 6.1.9 / Live 9.1.7
    • Mar 02 2015 | 10:18 pm
      I still have this problem every now and then, but it is always fixed by a restart (of the computer). If that doesn't help, it might be one the issues listed earlier in this thread.