Max not opening anymore (OSX Monterey)


    Nov 27 2021 | 9:15 am
    Hello, I recently bought a new macbook pro 14" with MacOSX Monterey. I downloaded and installed Max 8.2.0 and everything was running fine, working intensively with audio and video in very different patches during 2 weeks. Suddenly, Max stopped opening anymore. It was some time after I installed the MOTU drivers; at the beginning, everything seemed to work fine, but a couple of days later it suddenly stopped opening. I deleted every trace of the MOTU drivers in my HD but it didn't help. I installed the new max version 8.2.1 and same situation. I'm a bit of desperated because I cannot continue working and apparently Max 8 is the only version it will work with Monterey (I tried Max 7 and, as I expected, it crashes). I would appreciate some help. Thank you! Alberto Bernal

    • Nov 27 2021 | 1:20 pm
      Try to run max executable directly. It should run via Terminal, and post any errors
    • Nov 27 2021 | 10:23 pm
      Thank you for the reply. I run the executable and this is what the Terminal posts, then the max icon keeps blinking in dock during a couple of minutes and after that freezes. /Applications/audio/Max.app/Contents/MacOS/Max ; exit; alberto@MacBook-Pro-de-alberto-2 ~ % /Applications/audio/Max.app/Contents/MacOS/Max ; exit; 2021-11-27 23:19:51.289 Max[2403:67166] Max is starting: Version 8.2.0 (42e5454dc76) (arm64 mac) 2021-11-27 23:19:51.540 Max[2403:67166] jpatcher (attr default_plcolor) is using a deprecated color API and should be updated by the developer. 2021-11-27 23:19:51.540 Max[2403:67166] jpatcher (attr locked_iocolor) is using a deprecated color API and should be updated by the developer. 2021-11-27 23:19:51.540 Max[2403:67166] jpatcher (attr unlocked_iocolor) is using a deprecated color API and should be updated by the developer. 2021-11-27 23:19:51.727 Max[2403:67166] max_startmaxserver 2021-11-27 23:19:52.667 Max[2403:67166] sqlite version 3.32.3
    • Nov 28 2021 | 8:14 am
      why is max version 8.2.0 if you "updated" to 8.2.1 ?
      But I am not sure it has anything to do with that. that last line about sqlite version - it looks to me that max tries to build or rebuild database and hangs there. Did you allow Max to download packages ?
      Without user being noticed, Max builds database of whatever stuff it thinks is usefull to know about, scans audioplugins, writes converted medias files in cache (the ones that can't be played directly, like mp3 etc, get converted to aif and keep hanging in user's folder) etc etc. Or keeps history of used patches, crashes, tries to restore them ... Something probably got wrong there. I would delete all max preferences, actually entire cycling folder from users library. I can't offer any direct help, as I don't use systems higher than 10.13.6 But as I said - I would delete all max settings, stuff from documents etc. Just backup your own patches and work before doing so, maybe you allowed max to store your patches and projects into documents folder, and not where you want.
    • Nov 28 2021 | 9:38 am
      Thanks a lot again for your help. I deleted any trace of Max and Cycling74 in the library (both system and user), documents folder, any preferences in the libraries as well, and it keeps doing the same and giving the same notifications in the terminal. I also deleted later the "Info.plist" file from the max package, just to try, and since them it also notifies in the terminal: Thrift: Sun Nov 28 10:37:23 2021 TSocket::open() connect() <Path: /var/tmp/com.paceap.eden.licensed/authorization>: No such file or directory
      So, any additional help will be really appreciated.
    • Nov 28 2021 | 10:28 am
      this :
      jpatcher (attr default_plcolor) etc error is not important. The thing is max hangs for whatever reason, hard to say. You should put that info.plist file back. Or simply delete Max.app and copy it fresh from Max821_211116.dmg that would be the best to start with. Restart Mac. Then try following : open application Contents/Resources/C74/extensions/max/ and delete sqlite.mxo that should disable database. Start Max .... At least that can show if database is the problem. Another test would be to unzip Runtime.zip which is also located in resources. 2 executables Max Runtime and Max Runtime NOCEF are used to build Standalones, depending on CEF usage. You can place them into MacOS folder and run that instead of full Max, to see if that leads to full app start.
      At least that few infos could help trace the problem.
    • Nov 28 2021 | 1:57 pm
      OK. Deleting sqlite.mxo didn't help. But running Max Runtime and Max Runtime NOCEF both launch, and a quick test to a patch also seemed to work. And the terminal says: alberto@MacBook-Pro-de-alberto-2 ~ % /Applications/Max.app/Contents/MacOS/Max\ Runtime ; exit; 2021-11-28 14:55:55.205 Max Runtime[3683:142511] Max is starting: Version 8.2.1 (2f7eaf31afd) (arm64 mac) 2021-11-28 14:55:55.309 Max Runtime[3683:142511] jpatcher (attr default_plcolor) is using a deprecated color API and should be updated by the developer. 2021-11-28 14:55:55.309 Max Runtime[3683:142511] jpatcher (attr locked_iocolor) is using a deprecated color API and should be updated by the developer. 2021-11-28 14:55:55.309 Max Runtime[3683:142511] jpatcher (attr unlocked_iocolor) is using a deprecated color API and should be updated by the developer. 2021-11-28 14:55:55.500 Max Runtime[3683:142511] max_startmaxserver 2021-11-28 14:55:56.424 Max Runtime[3683:142511] sqlite version 3.32.3 The operation couldn’t be completed. Unable to locate a Java Runtime. Please visit http://www.java.com for information on installing Java.
      2021-11-28 14:55:56.505 Max Runtime[3683:142511] translation_getpreferredlanguage-> code: en-ES, name English
    • Nov 28 2021 | 2:20 pm
      I am afraid, I have no idea what to try next. Without being able to test directly on monterey system... Maybe you should try to contact cycling support. And why it suddenly asks for Java Runtime, it did work before without it, or ?
      You must be missing something, like installed packages or ... I don't know what. Anyway, if Max runtime versions both start and can activate and use audio drivers, then the problem does not relate to Motu Drivers at all.
    • Nov 29 2021 | 5:49 pm
      hi ALBERTO-BERNAL please get in touch with support - https://cycling74.com/support/contact
    • Nov 29 2021 | 7:30 pm
      Thanks a lot for your replies and tries. I will write to support, yes, and post back the solution (I hope there is one) for other possible similar cases.