Max Starting Very Slow on Windows

    MaxMSPbugs/issues

    bd's icon
    bd's icon
    bd
    Nov 23 2022 | 8:22 pm
    Max starts very slow on Windows 10 and 11. I try different machines, decent hardware e.g. AMD 5700U, 16 GB RAM. fast NVMe SSD. Other software behaves generally as expected. Disabling the "Virus &Threat Protection" did not help. I see nothing special in the processes, no excessive load on CPU. It takes minimum 35 seconds to start. It is empty Max of course, no patches loaded. Plugins scanning preferences set to "minimal/fast". I do not know what else I could optimize. Anybody else with that problem? PS. On my MB Air M1 with only 8 GB RAM it is almost instantly up and ready (<1 s).

    • Source Audio's icon
      Source Audio's icon
      Source Audio
      Nov 24 2022 | 8:27 am
      It could be database rebuild that maybe takes so long, in case you have some errors in the path or files that get scanned.
      I also remember 8.5.0 on Mac did initialise node.js even that I don't use it at all.
      I deleted all built-in packages anyway - don't need them. Only VIDDLL in case some video has to be used and that one can be loaded on demand. Since then Max starts as fast on both platforms.
      Share
    • bd's icon
      bd's icon
      bd
      Nov 24 2022 | 1:06 pm
      That sounds good! How did you achieve that? I tried to disable the packages, but impossible in the package manager. And if I just delete it I get some weird automatic 're-installation' when starting Max.
    • Source Audio's icon
      Source Audio's icon
      Source Audio
      Nov 24 2022 | 1:16 pm
      I simply go to Max folder/resources/packages and delete it. Or simply move it to some place out of max search path, in case you need it one day.
      I would do that first to check if that causes so slow start.
    • bd's icon
      bd's icon
      bd
      Nov 24 2022 | 1:22 pm
      Thanks. Does not work for me though, because if I delete them Max tries to reinstall them on Max startup again. Max wont start if I remove or hide the original installer and it cannot find it to reinstall the packages. Did you manipulate some preference files etc. to set the packages have been removed? I will experiment further ;)
    • Source Audio's icon
      Source Audio's icon
      Source Audio
      Nov 24 2022 | 1:51 pm
      I never Install Max on Winows, but extract msi package using msiexec. That way I don't need any installer, uninstaller, and it also does not bug me,if I want to keep and use different max versions at same time.
      Otherwise I did not manipulate any preferences, beside disabling automatic upates.
    • Wetterberg's icon
      Wetterberg's icon
      Wetterberg
      Nov 24 2022 | 7:09 pm
      >It could be database rebuild that maybe takes so long,
      this was the case for me; I had terribly slow behavior when instantiating new objects; turns out the culprit was the db looking in two folders that were nearly identical - basically a forked system in my dropbox.
      I deleted the pseudo-dupe and my rig sped way up
    • bd's icon
      bd's icon
      bd
      Nov 24 2022 | 9:47 pm
      Thanks guys! I don't know what you mean with database exactly. I have no errors in the console and the paths are clean. It was just a fresh Max install after 2 days old Windows install. Anyway, thanks for your answers. I decided to ditch that Windows though :D