maxwindow in standalone and midiinfo

    May 20 2013 | 8:51 pm
    Hi, I have two strange appearances: - before making a standalone app of my patch, I close all not necessary windows, especially also the Maxwindow. But, when opening the standalone the Maxwindow always appears. How to turn it off? I thought in the past this did not happen, but noe on 6.1 it does. Help!!!
    - I create the standalone on my desktop Mac with many MIDI-breakouts. When I copy the standalone to my MacBookPro which has only very few MIDI-breakouts I still receive all MIDI-Ins and Outs from my desktop when using the midiinfo for selection of the MIDI-out.
    Any ideas?
    Thanks for your help Hans Peter

    • May 21 2013 | 3:23 pm
    • May 25 2013 | 2:55 pm
      Hi 11Olsen,
      thanks for your response and help. Sorry, I tried to find something but without success, anyhow thanks
      But for the menu. This is strange, in my patch the umenu gets "loaded" with a midiinfo-box. I did not type the names into "Menu items" in the inspector. I understand that under these circumstances the umenu gets "loaded" each time it gets a midiinfo message. My patch has a loadbang to read the midiinfo and to send it to the menu. Does it mean that this way is not secure? Meaning that one never knows, if the information gets sent into the umenu or not?
      All the best
      Hans Peter
    • May 26 2013 | 4:56 pm
      it should be secure as the midiinfo object clears the umenu before appending new items. but a umenu saves it's entries with the patch, so if you're seeing the midi I/O of the computer you saved the patch on another computer in the menu that suggests the assumption the menu has not been filled with new values. O. edit: just try to clear menus before saving the patch so you would end up with empty menus if midiinfo doesn't work (extremely unlikely). the option for midisupport needs to be enabled in the [standalone] object.