mira.motion not working on Surface Pro 4


    Dec 29 2016 | 4:24 am
    (I already posted this on the Miraweb announcement thread, but I suspect it got buried under all the [well-deserved] accolades, so I'm starting a new topic in hopes that someone will notice and respond...)
    I’ve been testing Mira & Miraweb on a Surface Pro 4, which has (according to Microsoft) "Six sensors— accelerometer, magnetometer, gyro, ambient light sensor, Hall effect, Wi-Fi SAR" – but when I run the mira.motion patch, I’m only getting responses from Rotation Rate (in the Basic panel) and Raw Acceleration (in the First Gen panel). Nothing from Accelerometer, Compass or Orientation (in Basic), or Gyroscope or Magnet (in First Gen).
    Any idea why this isn’t working?
    Anyone?

    • Dec 29 2016 | 5:21 am
      Hey,
      Sorry you've been having trouble. Unfortunately, since Miraweb runs in the browser, we're only able to expose the sensor data that the browser makes available. So we're somewhat more limited than we are with, say the Mira iOS app. That being said, I would expect you to be getting more information than you are, so it's something we will look into for sure.
      -S
    • Dec 29 2016 | 11:44 am
      Definitely something worth looking into. Can you please give some more information on which Browser (incl. Version) you've been seeing this with? This would help us a lot when investigating further.
      Thanks!
      Florian
    • Dec 17 2020 | 12:56 am
      can't get mira.motion to work: iphone SE ios 14.1 broswers safari, chrome, firefox focus (all updated)
    • Jan 07 2021 | 11:46 pm
      I have the same probleem with safari an chrome on iphone.mira.status reports added and removed clients but mira.motion does not receive any sensor data from iphones using ios 14.3. I tried with an iphone 6s and a 12 mini. Both running on ios 14.3 It does work with an older iphone (5s) running on ios 11.2.5)
    • Apr 14 2021 | 11:15 am
      bump!