mxj not working on my Mac. what's missing?


    Aug 27 2013 | 9:04 pm
    Title says it - I just discovered that mxj objects aren't loading at all in Max 6.1 (6.1.3) on my MacBookPro. I get "Could not load class xxx" messages. I tried all of the ejies java externals, and some of the mxjs in the java-doc/tutorial/patches files (autocount1, HelloWorld1 etc). My assumption is that there is something overall that i haven't installed. If that's right, what might it be?
    thanks!
    Max 6.1.3 OSX 10.8.4. Macbook Pro Retina (Max in 32bit & low resolution modes)

    • Aug 28 2013 | 12:41 am
      Has it ever run on that computer? Java isn't installed by default on the Mac as of 10.7.
    • Aug 28 2013 | 5:04 am
      Make sure you are running the latest version of Java. A newer version of Max may contain objects that were compiled for a more recent version of Java.. and as Chris mentioned, Mac doesn't do java by default. So unless you are managing updates yourself, you are probably out of date.
    • Aug 28 2013 | 11:17 am
      ok - installed the latest version of java.
      Tried some mxj objects, and they work (I noticed that the tutorial examples need to be compiled first - so that's why they wouldn't work before - my bad).
      The ejies java externals (which is where i started with this) still don't work though - so I'll email Emmanuel again - unless anyone has any suggestions aboit why none of them would work?
      thanks
    • Aug 28 2013 | 9:39 pm
      ha!
      emmanuel suggested -
      move ej.jar to the /Applications/Max 6.1/Cycling '74/java/lib folder
      (from /Documents/Max/Packages/eijies_3.12/java-classes)
      and that fixed it.
      Is that a bug in Packages?