noteout not sending MIDI to Live via "from Max"


    Sep 01 2015 | 2:31 pm
    Hello,
    this is my first post since I have finally decided to sit down and learn Max. I am following Peter Batchelor's excellent tutorials and pretty much fell in the first hurdle. I am building a very simple patch where a number of messages send note values to makenote (with the arguments 127 200 for velocity and duration) then to noteout with the arguments a 1.
    Now I have tried this with Live, Logic and with the AU DLS Synth and got nothing. I've tried deleting the preferences file related to the DLS Synth and I've reduced the vector sig to below 1024 as some people have mentioned that this worked for them but to no avail.
    Any help would be very much appreciated
    Thanks

    • Sep 01 2015 | 3:49 pm
      Vector size shouldn't matter to send a signal. In max make your sending out from max 1. In live set max 1 in to on.
    • Sep 01 2015 | 5:10 pm
      Yup, did all that and made sure that the MIDI track in live has From Max 1 as its input. It's also turned on in both Max's and Live's preferences.
      One thing though, does the fact that I am using Max for Live to do all this make a difference? I mean is there some other object other than noteout that I need to be using given that it's Max for Live and not Max? (I think that question thoroughly demonstrates how much of a beginner I am).
    • Sep 01 2015 | 6:20 pm
      You cant use [noteout] from within Max 4 Live. You have to use the [midiout] object and send MIDI down through the track that the MIDI device is on. You must also be using a MIDI effect device, not an audio effect or an instrument. If you're just trying to generate notes to send into synths, use [midiformat] and [midiout].
    • Sep 01 2015 | 9:46 pm
      OK I have done all that, still nothing. I have been reading the reference and help files for each object I am using and to me the patch kinda makes sense, I tried it with [noteout] but with Max running outside Live and it all worked. However, when I opened max for live and replaced [noteout] with [midiformat] and [midiout], I am still getting nothing.
      Here are pictures of my very basic arpeggiator and I have it as a MIDI effect on track 1 sending MIDI to an operator on track 2, I am pretty sure it will end up being something really simple since I now know that the patch works with the [noteout] object in standalone.
    • Sep 02 2015 | 12:36 pm
      It seems that the right outlet of [makenote] is not connected.
      BTW, in my experience [noteout] also works in Max For Live.
    • Sep 02 2015 | 1:10 pm
      Yeah you're not sending two numbers into the pack object, so you aren't getting a pitch,velocity list into the [midformat] Broc is correct - noteout also works, I was referring to the fact that you can't send MIDI out from M4L by selecting 'from Max 1' or similar as the MIDI port to output on. It has to be sent on a track in Live.
    • Sep 02 2015 | 4:38 pm
      It worked! thank you so much for the patch, Evan, made things very clear for me. Now it's working with both [noteout] and [midiout]
      Thanks again!