performance problems (stuttering video)

    Jul 05 2013 | 7:08 am
    I am running some videos in jitter using opengl. (a videoplan and/or cornerpin). The videos loop. Really not a big deal I guess. However, since a while and specially on that computer, I video begins to stutter (dropped frames) more and more the longer the patch runs. The framerate on the render-object stays the same whatsoever.
    Is there a setting I am not aware of? Or maybe something even in OSX itself?
    The system is OSX 10.8 on a (hackintosh) MacPro. The videofiles are located on an internal SSD-Drive, which is as well the bootdrive.
    Any ideas?
    thanks! rené

    • Jul 05 2013 | 7:52 pm
      Please post a patch. SSd cards may not transfer data quickly enough unless you load the files completely into the RAM. What system are you using to trigger everything ? metro, qmetro ?? Optimizing open GL can be tricky at 1st. :) Could be one of a hundred things. And why Hackintosh if you have a fully working computer ?
    • Jul 05 2013 | 10:07 pm
      Same problem here
    • Jul 09 2013 | 7:11 am
      sorry for the late reply, had to finish the project.
      Well, I haven't found a solution only a work around this time. I made the movies shorter and don't automatically loop them, but "dispose" and "unloadram" the quicktime objects. That works in this case, as the videos don't get worse over the day, but of course is not a golden solution. A bit of stuttering is still there. The patch I am posting is just the simple base of movie-playback I am using normally (also tried adding things like colormode uyvy etc....).
      I found this interesting thread here: but it doesnt solve the problem.
      What really makes me wonder, that I don't have that problem on older machines.
      @andro: it is not an SD-Card, but an SSD-Harddrive, which is faster than a HDD-Drive. Anyway I put the project on a HDD-Drive without improvement.
    • Jul 09 2013 | 3:38 pm
      perhaps you will find improvements with
    • Jul 09 2013 | 4:43 pm
      same problem here.
      could not solve it. try to play a single 720p hap movie form ssd. loops fine, but it always stutters.
      also tryed to trigger the frames directly as described here.
      it does not stutter in quicktime player 7
      i have attached my testpatch with the testmovie included.
      is there any secret trick to avoid this hickups ?
      { "version" : "Version 6.1.3 (13a2369)", "platform" : "mac", "arch" : "x86", "osversion" : "Mac OS X Version 10.6.8 x86_64", "samplerate" : 44100, "iovs" : 512, "sigvs" : 64, "scheduler_in_audio_interrupt" : "off", "audio_drivername" : "Core Audio", "audio_driver_subname" : "", "eventinterval" : 2, "overdrive" : "off", "mixerparallel" : "on", "mixercrossfade" : 1, "mixerlatency" : 30.0, "mixerramptime" : 10.0 }
    • Jul 09 2013 | 5:02 pm
      I tried MR.L's patch with a 720p 24fps H.264 8Mb/s video streamed from a 7200rpm HD. Plays fine without stuttering. Please note that H.264 is a bad codec for Jitter realtime stuff. A codec that doesn't do temporal compression (grouping of successive frames) like (M)JPEG is better.
      A 1080p movie at 39Mb/s did stutter significantly.
      My machine is an i7 @ 4GHz with 8GB RAM and a GTX670 gfx card.
      Bottom line: there are many many factors involved in video playback. Be sure to exhaust all optimization options.
    • Jul 09 2013 | 5:12 pm
      Tried HHLET's as well. Normal playback works fine, no stutters. Framedriver method didn't work (I mean, at all, video stays on start frame).
      Some tips: use qmetro instead of metro and don't set it to something extremely low like 1.
    • Jul 09 2013 | 5:13 pm
      thanks for answering dtr ! i thougth using the hap codec with ssd and drive the frames directly is the actual best optimization ...
      perhaps you can post a simple patch with a 720p movie, that does not stutter.
      that would be nice for all of us, who have this problem.
    • Jul 10 2013 | 1:09 pm
      hi dtr,
      our forum answers overlapped ;-) strange, that the Framedriver does not work on your machine. here it works fine.
      thanks for the tip with the qmetro. but it does not help against the stuttering.
      perhaps rob has a secret tip how we can drive our clips free of stuttering.
      best, hhelt
    • Jul 10 2013 | 5:52 pm
      definitely don't use metro to drive an opengl context. you also shouldn't bang a to output a frame, the object is an automatic opengl object, so it outputs a frame when the gl.render context is banged.
      switching the metro to qmetro makes your patch work for me without stutter for both techniques.