PNG files not working properly in 64 bit mode

    Jan 22 2014 | 11:16 pm
    Weird problem. Loading in PNG files without "start in 32 bit mode" option enabled on OSX creates a heavily artifact-ed image. This is a problem because I have the opposite problem with jit.qt.grab, which is that it only works in 64 bit mode. Any ideas?
    latest version of max, osx 10.8

    • Jan 22 2014 | 11:50 pm
      What objects are you using to load the PNG files?
    • Jan 23 2014 | 12:05 am
      I've tried importmovie on a matrix and also a simple, same results.
      Looks like the attached file.
    • Jan 23 2014 | 12:28 am
      I can confirm that there are some issues with .png files only on Window x64. We will take a closer look, thanks!
    • Jan 23 2014 | 12:29 am
      Odd. Within minutes of replying to this thread I had the same happen on my system… except it's not happening to all PNG files. Only some of them. Do you have the same problem with both of the attached pics or just one of them…?
    • Jan 23 2014 | 1:09 am
      Ben, this is also happening on Mac osx 10.8.5 .. but it only seems to be affecting certain PNGs. The colorchecker image I attached in the previous post doesn't decode properly with while the koi image decodes just fine.
    • Jan 23 2014 | 1:53 am
      Correction: by 10.8 I meant the latest version of 10.8, which as you report is 10.8.5
      Also, Metamax, I am having the same experiences with those PNG files. I tried several different formats but couldn't make my own PNG files behave. The Koi works fine.
      So glad it isn't my computer!
    • Jan 23 2014 | 2:34 am
      Well that's just it.. the koi pic is a PNG file… I think there are different PNG encoding methods that process rows of pixels differently. Most of the PNGs I have been using work fine.. so you might consider reprocessing your images with a different editor to see of you can get a version that works in qt.. until it's fixed.
    • Jan 23 2014 | 2:53 am
      What I mean is that I did try several methods, to no avail! Both in PShop and Preview. Weird. Also, PNG files generated via Processing are not showing up well :( Hopefully this is a bug that Cycling will fix soon?
    • Jan 23 2014 | 3:30 am
      This may or may not be helpful for your project but QT can read the PNG properly if the image has square dimensions. All of the images in my current project are square so I didn't notice a problem.. except the colorchecker image is 300x200.. so it didn't decode properly. As soon as I resized it to 300x300 it displayed properly.
    • Jan 23 2014 | 8:39 pm
      Good tip, thank you!