Problem with buffer~ in Sierra : some wav or aif files won't play


    Jun 06 2018 | 3:25 pm
    As described in this thread (https://cycling74.com/forums/macos-x-sierra/replies/1#reply-5b17ca2a08521d4ecca652a6), it is now clear that my Zoom H6 files, which I previously used without any problem in MacOS 10.8.5 in Max, won't play with the buffer~. The error message reads "cannot open parser for this file". Is there a solution for this problem ? I can post an example file if someone can have a look at it ?

    • May 29 2020 | 10:29 pm
      Did you solve this?
    • May 30 2020 | 9:56 am
      My workaround was to convert the files through an app (I think it was Myriad) from wav to... wav.
    • May 30 2020 | 10:49 am
      Thats crazy. I let users pick any files they want. What is corrupting the file import? Is there a workaround that can fix the files built into max that way Users dont get frustrated? I went from using ~SFplay to the new MC.Play using buffers~. Users claim the files wont playback even though it worked in the previous update with SFplay.
      Really need a workaround,
      Sam
    • May 30 2020 | 1:24 pm
      from extension .wav one can't tell if wave file is compressed or not. Uncompressed PCM waves allways worked in all max objects able to load audio files. compressed ones allways made troubles.
    • May 30 2020 | 1:27 pm
      I've reproduced a Buffer~ problem with consistency...
      • Problem with FILE PATH - If a folder or file has any of the SLASH characters "\" or "/" then it causes an issue with import. In essence the slash character is fooling the importer to look for a folder that doesn't exist. For example: If a folder is called "Audio / Files".   this is going to break the importer.
        • Fix - Rename the problematic folder/file
      That doesn't necessarily solve any corrupted files but it is an annoying problem I had run into.
    • May 30 2020 | 2:53 pm
      Could it be related to this old story :
      I'd be curious to get a short file from your H6.