Problem with compiling files with csound~ in Max/MSP

    Jun 13 2018 | 3:46 pm
    I'd like to ask for help in a strange issue that I'm having with the csound~ 1.1.3 object.
    The problem is that any .csd file I try to open with the csound~ object cannot be compiled. The Max console shows the following message:
    csound~: UnifiedCSD: [The directory of the .csd, but, for some reason, always with a different mistake, like an extra or missing slash, an extra letter, so on...] csound~: Reading CSD failed ... stopping csound~: csoundCompile() failed.
    When I double click the object it tells me the following:
    csound~: Could not convert [the directory, but again, with a random mistake] to FSRef.
    Now, what I found specially strange is that, using the help file of the csound~ object, all seems to work fine, but if I change the .csd file, the problem reapears (even if I change to an exact copy of the .csd used in the help file) If I just copy and paste the hole help file in another patch, it stops working and the "Could not convert to FSRef problem" message appears again.
    Can anyone help me?
    This is happening in a Mac 10.12.3, with Max 7.3.5 and, as I said, the csound object is the 1.1.3, with Csound 6.04 installed.
    Thanks in advance!!

    • May 20 2019 | 4:29 pm
      This is an intermittent issue that I have been getting as well, but I'm not sure what causes it, nor what lends itself to resolving on its own. You may wish to submit a ticket here , but the guy who has volunteered to maintain the object hasn't really been doing anything with it. I'm sorry I don't have a better answer, as this has been a burning question for myself, as well. I think the object needs to be recompiled, frankly.
    • May 20 2019 | 6:43 pm
      Myrddinemrys, I actually solved the problem a couple of days after I had it but I never posted the solution. Anyways, the problem was really really simple: the .csd file used as argument in the csound~ object needs to be in the same directory as the .maxpat which the object is been used. Even if the .csd is in somewhere which Max has access of via the File Preferences, it doesn't work. I don't know if that's the same problem you're having, but that's how I permanently solved my own.