snding audio via UDP

    Feb 03 2013 | 8:05 pm
    Hello guys, I'm trying to send audio signal from a max patch to another max patch (different laptop). I'm trying with but I'm probably mission something and it's not working. Any suggestions?

    • Feb 03 2013 | 8:05 pm
      here's the patch
    • Feb 03 2013 | 10:50 pm only works with matrices. You need to convert your MSP signal to a matrix, as in the "audio-over-network" patch in the jitter-examples/audio folder.
      Or you can try the netsend~ external:
    • Feb 04 2013 | 12:39 am
      Another two possibilities would be to use JackTrip ( ), or the AUNetSend/AUNetReceive pair of audio units (I think they are shipped with XCode, but not sure about this).
      Hope that helps, Ádám
    • Feb 04 2013 | 1:41 am
      I think netsend is not working with max 6 and unfortunately Ive tried the AUNetSend but it's crashing in about 2 seconds... I'll have a look to the jitter examples and jack trip, thanks guys
    • Feb 04 2013 | 2:54 am
      whats wrong with TCP?
    • Feb 04 2013 | 3:45 am
      UDP is usually better for real-time stuff, better to drop the occasional packet than introduce delays.
    • Feb 04 2013 | 8:22 am
      I've had good results using netjack2, which is installed with jack. Also reastream vst on windows
    • Feb 04 2013 | 2:46 pm
      so I'm using Here's another issue: if i send audio within the same patch everything is working ok, but then I tried with two different laptops (I created a network, connected both laptop to the same network, checked ip and port) but couldn't received anything....
    • Feb 04 2013 | 3:26 pm
      The sender and receiver objects report their connection state. Do they link?
    • Feb 04 2013 | 4:51 pm
      they don't connect. Actually I have this error message on max window "data is being input faster than i can be sent" here are the parches..
    • Feb 04 2013 | 5:49 pm
      Perhaps take a peek at Zach Poff's patch:
    • Feb 05 2013 | 5:48 pm
      the sender patch connects but the receiving one more step forward!
    • Feb 05 2013 | 6:15 pm
      Max Patcher
      In Max, select New From Clipboard.
      You forgot to write "ip" after the first @ in the receiving patch.
    • Feb 06 2013 | 9:05 pm
      yes I've already changed it!