Syphon and Spout for GL3


    Aug 27 2019 | 9:15 pm
    Hey everyone for those of you sinking your teeth into the GL3 package, make sure you update your version of Syphon or Spout (depending on your OS) to the latest version in the Package Manager (v 1.0.6 for Syphon, and v 2.0.72 for Spout).
    These latest versions will support texture sharing in GL3.

    • Aug 27 2019 | 11:28 pm
      I can confirm that Syphon works flawlessly with GL3.
      I tested recently relatively complicated setups with many servers and clients working simultaneously, transparency support (which was often a problem), transmission between Jitter and other environments (e.g. Processing), etc. I haven't experienced any problems.
    • Sep 04 2019 | 3:41 pm
      Hi,
      yes Syphon works, however this message appears in the Max console when I use jit.gl.syphonserver : 'jit_gl_texture: mode is obsolete when using the gl3 engine'
    • Sep 04 2019 | 4:33 pm
      thanks, i've seen those too. you can ignore for now but I'll get them removed for the next update.
    • Oct 21 2019 | 1:21 pm
      Question for Rob:
      I added GL3 to my 8.1 version, changed prefs and it runs fine. Now 8.05 (which opens automatically with the same prefs as 8.1) crashes immediately - because it can't run GL3 - and won't let me revert to GL2. I want to run some patches with GL2 and some with GL3 while I learn it.
      So can I just reinstall 8.05 and not add the GL3 package and will the 2 versions then keep their own prefs and packages and work independently?
      Thanks,
    • Oct 22 2019 | 5:10 pm
      Hi Bob.
      This crashing on 8.0.5 is an unfortunate oversight we missed when developing the render engine backend for Max 8. You can either modify the max 8 preference file in a text editor to change gl3 to gl2, or you can open Max 8.0.8+ and change the preference there, and then open max 8.0.5.
      There is currently no mechanism to manage multiple preference files for different versions of Max 8. The solution I use for this is a script to launch max. 1 for gl2 and 1 for gl3. The script uses this json editor tool called jq to edit the max-preferences file, and then launches max via the arch command: gl2 script below. change gl2 to gl3 for the gl3 script.
      #!/bin/bash
      cd "/Users/yourusername/Library/Application Support/Cycling '74/Max 8/Settings"
      mv maxpreferences.maxpref temp.maxpref
      jq '.preferences.glengine |= "gl2"' temp.maxpref > maxpreferences.maxpref
      rm temp.maxpref
      arch -x86_64 /Applications/Max.app/Contents/MacOS/Max
    • Oct 22 2019 | 5:16 pm
      Thanks a lot for this Rob. Much appreciated!
    • Apr 14 2020 | 11:27 am
      it is not working on my machine: i am running the latest max version on mojave 10.14.6 on a macbook pro 2017 with a Radeon Pro 560 4 GB graphic card. even the simple syphon server help patch doesnt work as intended. what am i doing wrong?
    • Apr 14 2020 | 3:42 pm
      Hi again, Linden. In the help file example above, does putting a jit.gl.slab or jit.gl.texture between jit.noise and jit.gl.syphonserver make any difference? Also, have you tried receiving the Syphon texture with any other clients besides "Simple Client"?
    • Apr 14 2020 | 4:32 pm
      what's printed in the Max console? (restart Max and open this patch to get the full console output)
      does the following simple patch work any better?
    • Apr 14 2020 | 5:10 pm
      hello rob, your comment put me in the right direction: to observe the max window more closely:) so i found the mistake. i had multiple syphoserver.mxo in my search path. this happened because i defroze some max for live devices which had also syphonserver in use. hi perdo, thx again. the helpfile for the syphonserver uses only 1 plane noise. so i put a gl.pix in between with vec 0 0 0 1 hocked up to the input. this solved it. it seems that gl3 seems to have changed the behaviour here since when i use gl2 there was no problem! thx again. i am happy now to use syphong with those gl3 patches:)
    • Jul 15 2020 | 9:10 am
      Hi - is it normal that after installing the latest spout version 2.0.72 from Package Manager and placing a jit.gl.spoutsender object into a patch - max console states
      jit_gl_spout_sender - Vers 2.0.6.0 (64 bit)
      jit_gl_texture: mode is obsolete when using the gl3 engine
    • Jul 20 2020 | 2:56 pm
      yeah that warning is harmless and can be ignored.
    • Apr 30 2021 | 7:25 pm
      just a quick note to say that Syphon version 1.0.7 is now in the PM, this fixes a few minor things:
      • no more warnings printed when using in gl3
      • no longer a requirement to set @layer to a high value when sending a jit.world context (it is set implicitly)
      • fixes for setting @servername in jit.gl.syphonclient and jit.gl.syponserver and @appname in client as attribute arguments in the max box.
      • new launcher patch
    • Sep 11 2021 | 4:38 am
      Hi @Rob I am running the latest Max8 version and getting 2 problems with spout: 1- in gl2 the spoutsender gives out a bad glitched image 2- if I activate gl3 it doesn't give any output
      I erased already the max installation and reinstalled it but nothing changed. Do you have any kind idea of what could be the problem? Thanks a lot!
      with Max8 and gl2
      with Max8 and gl2
      no output activating gl3
      no output activating gl3
    • Sep 13 2021 | 3:54 pm
      which version of Max?
    • Sep 14 2021 | 5:46 am
      Hello Rob, thanks a lot. I solved the issue installing Max 8.2 beta. It looks now to work correctly. Just a curiosity, at the time of this discussion opening you where using Max 8.1.11 or previous versions? I still would like to understand why it wasn't working fine :) Thanks a lot for your kind attention and reply
    • Sep 14 2021 | 8:39 pm
      I have just tested the latest Spout package on windows with both gl2 and gl3 engines using both Max 8.1.11 and the Max 8.2 beta, and had no issues.
      Please first make sure you follow the steps here to ensure you have proper versions of both Max 8.2 (if using) and the gl3 package - https://cycling74.com/forums/gl3-package-conflicts
      Please also make sure all applications you wish to use Spout are all using the same GPU, this article may be helpful for that - https://support.serato.com/hc/en-us/articles/202305784-Changing-graphics-card-settings-to-use-your-dedicated-GPU-on-a-Windows-computer-