Syphon / Jitter Colour issues


    Jan 12 2021 | 4:20 pm
    I'm capturing some OpenGL Jitter animations with Syphon Recorder as .mov files.
    RGB Colour values are appearing altered and washed out when captured.
    Is there a colour profile setting I'm missing?
    I've tried the different compression settings in Syphon, different video engines in Jitter, capturing direct via jit.record, exporting with different codecs via Adobe Media Encoder, and uploading to Vimeo etc. all with the same / similar results.
    Only VLC seems to preview the correct RGB values but not anywhere else I need so far.
    I'm looking for accurate colour capture for uploading to Vimeo etc. Any pointers greatly appreciated.
    I'm sure I'm approaching this a little ass-ways.
    .png's of Jitter vs. QT attached
    jit.world screenshot
    jit.world screenshot
    QT screenshot
    QT screenshot

    • Jan 13 2021 | 6:14 pm
      unfortunately I think this is a problem with Syphon Recorder not properly utilizing an HD color profile. I'm not super knowledgable about this stuff, but usually if the HD profile is included then it will display in the get info window, under more info :
      This is not the case with syphon videos, but jit.record does properly add the profile. so maybe you can use jit.gl.asyncread-> jit.record instead of syphon recorder.
      I'm not sure if there's a way to add this profile info after the fact, or what VLC does to properly display the colors.
    • Jan 15 2021 | 1:40 pm
      Thanks for the reply Rob.
      jit.record seemed to be dropping my frame rates unfortunately so I decided against it. I went back to the older Syphon Recorder version 15 and it had an uncompressed .mov capture option I didn't see in the latest version which works great. I can now also capture audio directly into Syphon which I was unable to do previously. Gargantuan file sizes of course. Yet still any further compression afterwards is bleaching colours again. More digging ; )
      I'm running Mojave so perhaps that's where the latest version of Syphon was having issues.