Forums > MaxMSP

Fiddle~ for Max Runtime

May 10 2013 | 10:32 pm

I have some old patches from school made in Max 4 with fiddle~ v1.2. I would like to use these patches on my home computer. I downloaded Max 6.1 Runtime but it shows an error in the Max Window saying no such object when I load one of the patches.

fiddle~: No such object

I tried to add the fiddle~.mxo file found here:

I downloaded the "fiddle~ version 1.2 for Mac Max/MSP OS X Mach-O Universal Binary with source" file and then added the fiddle~.mxo file to the msp-externals folder for Runtime, which is located in the applications folder. Applications>Max 6.1 Runtime>Cycling ’74>msp-externals

But I’ve loaded, re-loaded and restarted the machine, still getting error "no such object". What am I doing wrong? Is there a solution to this?

May 10 2013 | 10:34 pm

Also, currently I am running Max 6.1 Runtime on OSX 10.8 on an Intel Mac. I’m pretty sure the comps I was using back in school were pre-intel Macs.

May 10 2013 | 11:29 pm

Max 6.1 is 64-bit and doesn’t work with 32-bit objects. If you get info on the app, you can check "Open in 32-bit mode". That should work.

EDIT: I’m wrong. The error in this case is:
fiddle~: unable to load object bundle executable

fiddle~ 1.2 works for me with Max 6.1 runtime in t32-bit mode.

May 11 2013 | 1:07 am

Awesome! Thanks mzed! I took a look and Runtime was already in 32 bit mode so I switched it over to 64 bit and got this error:

2013-05-10 19:32:26.158 Max Runtime[1070:c07] Error loading /Applications/Max 6.1 Runtime/Cycling ’74/msp-externals/fiddle~.mxo/Contents/MacOS/fiddle~: dlopen(/Applications/Max 6.1 Runtime/Cycling ’74/msp-externals/fiddle~.mxo/Contents/MacOS/fiddle~, 262

): no suitable image found. Did find:

/Applications/Max 6.1 Runtime/Cycling ’74/msp-externals/fiddle~.mxo/Contents/MacOS/fiddle~: no matching architecture in universal wrapper

So then I went back into Get Info and set it back to 32 bit mode at which point fiddle~ was recognized but I got this error:

"fiddle~: out of memory error"

I searched that error and found the final step here:

"It should work if you include the four arguments: [fiddle~ 1024 1 20 3]. They should be set by default but I get the same error message unless I set them explicitly at instantiation. Hope this helps."

Luckily I have some patches with that already set like that for fiddle. Those are operational now. Now if I can find a way to re-edit these old patches to include the extra paramaters I’ll be set. Thanks again!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP