Forums > Max For Live

lhmidiin / lh_midiout updates

August 12, 2012 | 2:22 pm

Hi there,

Just to let anyone who needs to know know, my lh_midiin/lh_midiout externals are now available from here
… no thanks to mobile me shutting down!

You’ll notice there is an update to these externals,An anomaly when using multiple controllers of the same kind (e.g. 2 x launchpads) causing ports to get confused is now fixed (I hope!)

You might also notice that I have another external lh_smidiin, which is a stream of ints output version of lh_midin (which outputs formatted lists).
This will enables the passing of very long sysex strings.


Regards, Leigh

August 13, 2012 | 4:50 pm

this is epic! max on osx has now reliable midi connection that survives the disconnecting and reconnecting of devices! works with my two bcr2000s…

October 1, 2012 | 3:41 pm

Hi all,
Links to these objects are now in the tools section of the c74 site

November 14, 2012 | 10:41 pm

Hi leigh.
I am trying to use your externals. But they don t seem to work for me. I was using the old ones, and they worked. I m using the MFL version of them. Live 8.2.6, osx 10.7.5, max 5.1.9. Any ideas?
Thanks in advance

November 15, 2012 | 1:55 pm

no windows OS love? :-(

November 22, 2012 | 4:48 pm

Hi there – I know I answered you privately from your private message YTX. I just wanted to mention to others, that the latest version 1.03 is for Max6 upwards. The older V1.02 is for Max5 upwards.

December 3, 2012 | 4:42 pm

Anyone else having problems getting the lh_midi objects to work as expected? I’m using Max 6.0.8, and Live 8.3.4 on MacOSX 10.7.5. I’ve installed the .mxo files in in the m4l-externals directory, and the .mxohelp files in the m4l-help directory.

When I try to instantiate either of them in my patcher, I see the auto-complete in the popup when I type either of their names, but the object itself does not work. Instead, it is darkened and has no inlets or outlets, as if the object name is misspelled or is not installed. No messages appear in the Max window, so it seems to think these objects exist—but it just won’t let me work with them. Here’s a screenshot to show you what I mean:

Anyone have any ideas?

Thanks in advance for any & all help!

December 3, 2012 | 5:39 pm

Aha—looks like I managed to figure this out. It looks like I have to use v1.0.2 of the externals instead of v1.0.3 for some reason. Once I switched to v1.0.2, everything is functioning as expected.

Leigh, is this a known issue with v1.0.3 and Max6 + Live 8.3.4?


December 4, 2012 | 1:05 pm

Hi Adam – further to my message to you – I’m using Max6/Live8.34 with the 1.03 version of the objects. I’ll check when I’m home next week as to whether there are any issues my end (I haven’t been actively using them recently), and let you know. Thanks, Liegh

December 5, 2012 | 4:21 pm

Hi Leigh… awesome, thanks for the response. Not quite sure why 1.03 wasn’t working, either—but 1.02 definitely does the trick. I’m able to send sysex along with all the usual data from my M4L device now. Thanks again for the excellent externals..

February 13, 2013 | 2:44 pm

hi everybody, i was wondering if someone has experience with the lh_midiout, live9beta and max 6.1 beta. i was able to get 1.02 to work (1.03 didn’t work for me at all – was grayed out), and send midi clock msgs only while editing the patch, when the patch is locked, it does not work.
im on mac os 10.8.2

any help would be appreciated!

March 13, 2013 | 12:10 am

Hi Leighhunt.
I can’t get lh_smidiin to work (max 5 and 6, not in m4l either) on osx 6.8. The object is greyed out with no inlet/outlet.
If I open the help file, it has inlet/outlets, but is still grey.
Any idea.

May 18, 2013 | 5:20 pm

Hi Leighhunt,

I have the same problem as Crampe, I am now looking into creating a programmer for my hardware old synthesizers in sysex and have been trying this udp midi bridge workaround to no avail…

I eventually found your objects but they do not work, neither version 1.0.2 or 1.0.3
I am using max 6,1,2 and live 9,0,2.

Do you know if this is related to my version of the programs ? that would be a shame since my main purpose with m4l is to use it for it to create this programmers…

thank you

September 13, 2013 | 5:00 am

Hi Leighhuunt.
Do you have any plan on doing a 64 bit version of your objects ?

September 13, 2013 | 5:39 am

Crampe do you mean that those won’t work on any 64bit mac ?
Cause if i’m not mistaken the latest 32 bit macs were built in 2010, and the latest version of those objects is more recent than that !

anyway that would explain why they are not working for me…

anyone with an answer ? my matrix6 and ex-8000 are dying for a live programmer !

September 14, 2013 | 4:32 am

No Gajimicu. They work on 64bit mac.
But they don’t work with the 64bit version of Live 9.

September 14, 2013 | 4:37 am

Wow this is incredible news !!
I just checked and I have the 64bit version of live 9 ! this is a game changer, I think I’ll have to switch to 32bits version then.
Any drawbacks from doing this you might think of ?

Thanks a lot for this info, might be useful for other people around here too.

September 14, 2013 | 6:27 am

The only possible drawback is that the 32bit version can’t use more than 4gb of ram.

September 17, 2013 | 1:41 am

I’d like to jump into this thread as I am experiencing the same issue as discussed above by Crampe and Gajimicu. lh_midiout is greyed out with no inlets/outlets, yet the help file loads and has ins/out on the object and no error message displays in the max window.

Using lh_midiout v1.0.3, Live 9.0.4 (32bit) Max6.1.2 (32bit) OSX 10.7.2. I have tried previous version of lh_midiout, however this also did not work but did not appear to be greyed out.

I am trying to use lh_midiout v1.0.3 to send sysex messages to an external device from within Live. I am not sure if lh_midiout will work like the standard midiout object and will route sysex info through to the midi channel in Live, or if you are meant to select the device from the umenu within the M4L patch- this seems like it maybe the logical way.

If anyone can advise, that would be great!

December 11, 2013 | 8:13 pm

Hi Leigh I’d just like to implore you to take a look at lh_smidiin and see if you can get it to run.

I’m desperate to get a m4l patch managing long sysex streams working in live.

I would be eternally grateful, these objects totally define my studio.

FYI I couldn’t get 1.03 to work either, 1.02 has been working great but can’t handle the longer streams.


January 22, 2014 | 4:45 am

this is quite a smooth and stable alternative to the java externals in M4L, I am very delighted to have found them! Thanks for coming up & sharing this LH!

The lh_midiin and lh_midiout objects work and aren’t greyed out or the like (just the lh_smidiin leads to the problem ADAMLWATSON described earlier).

>>> However, I haven’t found out how to fetch the MIDI data and edit it… in the java solution, a simple midiparse-object gave me access to all incoming MIDI data I had to later format and group, but with the lh-objects I am pretty much clueless and don’t know how to parse, edit or reformat it!??!? How do I access and work with it??

Would be great if someone could gimme sum guidance ‘ere… thanks!
& Great job!

May 16, 2014 | 5:00 am

I’d love to port this external to 64 bit… but I don’t even know what a C+ line looks like :-)
Would someone here with knowledge be able to port this without headache ?

April 26, 2015 | 3:03 am


I am trying to use lh_midiinout in M4L to send Bank and Program changes to an E-mu Virtuoso 2000.
I set up a patch that works fine when using the midiout port of Live, but does not work when using lh_midiout instead.

With V1.02, I get invalid bytes (as seen with the MIDI Monitor app), when sending the midi messages.
With V1.03, the lh_midiout object does not have any inputs or output ports and does not even show up in "List Externals and Subpatcher Files".
I tried relaunching both Live and MAX before each trial.

My goal, once this works, is to build a complete controller for that synth, so I will later need to use SysEx (which is why I am trying to use lh_midiinout).

I am on a Mac with OS X Yosemite 10.10.2, with Live 9.0.6.

Any help or hint appreciated.

April 27, 2015 | 4:52 pm

my d550 would be "externally" grateful if issue as discussed above by Crampe and Gajimicu was resolved. I’m all grey! no inlets or outlets. Help!

December 9, 2015 | 12:12 am

I would like this to work as well. Any progress?

December 9, 2015 | 2:42 am

the solution arrived:

Viewing 26 posts - 1 through 26 (of 26 total)

Forums > Max For Live