Forums > MaxMSP

Max 6.0.3 Released


Jan 04 2012 | 11:58 pm

Over the last few weeks, it came to our attention that there were some critical issues that were introduced in 6.0.2 that we needed to fix in short order, so I’d like to present to you Max 6.0.3. There are no new features to speak of. Fixes included in this installer are:

Core Audio: Fixes for various crashes, especially when audio inputs are greater than two
adc~/dac~: Poundsign arguments (#1, #2, etc) work again in object box
patch cords: can change color (Windows)
jit.phys.ghost: help patcher now opens (Windows)
polybuffer~: help patcher now opens (Windows)
jit.phys.multiple: Misc. fixes

Please let us know if you see any problems with the above fixes.

You can find these installers on our Downloads page:

http://www.cycling74.com/downloads/

All the best,

-Ben

Jan 05 2012 | 1:17 am

Hi,

thanks for the update. My question still: did the bug described in this thread: http://cycling74.com/forums/topic.php?id=36114 get fixed? It was told us that the bug would likely be fixed in 6.0.2, however, it was not mentioned in the change log and I got no response when I asked about this. I know, I could just install Max 6 and see what changed for myself, but unfortunately I can’t afford the time to mess with my file preferences again. So I won’t even think of installing the software until somebody wouldn’t confirm that this bug has been fixed…

Thanks,
Ádám

Jan 05 2012 | 1:18 am

Installed for 10 minutes and crashed twice already…

Macbookpro, running 10.7.2

Jan 05 2012 | 1:42 am

@Ádám We changed the app identifier for 6.02

@Rodrigo sorry, without details there is nothing we can do to help.

-A

Jan 05 2012 | 3:37 am

Just to be clear, changing the app identifier means that Max 5 and 6 can now peacefully coexist and a simple ChangeAll will allow me to change the default app? I’d love to get back to being able to test my productin code with Max 6

Also happy to see that the # args work again.

Let me also add how appreciative I am that updates are coming quickly to address these issues.

Jan 05 2012 | 5:39 am

‘Change all’ should work fine now.

-Ben

Jan 05 2012 | 2:13 pm

trying this one
not a lot of problems with 6.0.2 (w/ your last coreaudio fix), btw

Jan 05 2012 | 2:28 pm

Yes — change all does work now — terrific — back to testing with 5 and 6

Jan 05 2012 | 7:58 pm

After crashes I keep getting weird error messages too. I’ve seen "poke~ is not an object", followed by all the red disconnecting patch cable messages a few times now.

Jan 05 2012 | 8:01 pm

Hi Rodrigo,

Sounds like you have some machine-specific issues going on. Please email support at cycling 74 dot com and we will take it from there.

Thanks,
-Ben

Jan 05 2012 | 9:26 pm

Can somebody explain what this ‘change all’ thing is? Where can I read about it?

Jan 05 2012 | 10:42 pm

You can read about the original issue here:

http://cycling74.com/forums/topic.php?id=36114

Basically, on Mac, you can specify an application to open all files of a certain type by default. This was not working properly in the last version of Max, but has been fixed in 6.0.3.

Viewing 12 posts - 1 through 12 (of 12 total)

Forums > MaxMSP