Forums > MaxMSP

ps3 eye webcam doesn't work on Mountain Lion

September 19, 2012 | 10:14 am

It seems Mountain Lion doesn’t support madam driver for ps3 eye webcam.
Anyone have the same problem?
I get only one still frame.

September 19, 2012 | 12:02 pm

Working here – MBP 2.53 C2D, OSX 10.8.1.

September 19, 2012 | 12:19 pm

On my MBP OSX 10.8.1 I can use ps3 with max but not with the "macam application"
On my MacMini Max6 can’t use ps3 eye and "macam application" doesn’t work.

@bdc Does your "macam application" work? Can you send me a copy to try here? Thanks

September 19, 2012 | 12:49 pm

Haven’t tried the macam application – only ever use the camera with max. Since this is a Max forum, I figured the intent was to use the camera with Max. I can try the macam application this evening.

September 19, 2012 | 6:48 pm

Macam works for me, I’m on 10.8.1

September 19, 2012 | 7:07 pm

Thanks for your report Barry, are you on MacBook Pro or other?

September 19, 2012 | 7:21 pm

Doesn’t works for me in Windows 7

September 19, 2012 | 7:32 pm

Macam is for mac only, for window driver try to search here

September 20, 2012 | 1:39 am

Tried the macam. The preview window in macam looks like it’s capturing a single frame, although the status across the bottom does report a frame rate that varies slightly – I imagine it is reporting what the driver is doing. And clicking Record causes macam to crash.

September 21, 2012 | 11:30 am

Mac Mini, here is la spec:

Processor 2.3 GHz Intel Core i5
Memory 5 GB 1333 MHz DDR3
Graphics Intel HD Graphics 3000 384 MB
Software OS X 10.8.1 (12B19)

October 26, 2012 | 9:29 am

I’ve just purchased a macbook pro and on this machine the PS3 eye has now stopped working :(

May 13, 2014 | 8:57 pm

I have been experiencing problems with this as well. I have the single frame grab issue referenced by BDC, I have only got the feed to come through on CommunityCoreVision (CCV), and have got the audio to come through in QuickTime – but nothing else. I tried installing the driver in several places but no luck.

I am running 10.8.5 Anyone have any breakthroughs?

May 14, 2014 | 11:29 pm

I’m on 10.9, but Apple seems determined to transition away from QuickTime and to AVFoundation – it wouldn’t surprise me if this was relevant to 10.8 also. Not really a solution, but I finally gave up with macam et al and bought a couple of Microsoft LifeCam’s; they seem to run without any troubles.

May 15, 2014 | 5:12 am

I needed to install Quicktime Player 7 to get mine to work . Now its fine.

March 23, 2015 | 10:03 am

Reviving an old post…
I just found out that some good fellows have released the sources of a new ps3eye driver that should work under Mavericks:

I don’t have any coding skills to build an external based on these sources, but maybe someone could be interested in helping save these good old cameras from obsolescence?

April 8, 2015 | 5:58 pm

I am also very interested in making sure this piece of technology continues.

The fact that you can get a PS3 Eye on Amazon for ca. $10, 3D print enclosures for them, hot swap lenses, control all camera lighting options in software, and specify a wide range of resolutions and frame rates (all on a USB) makes this just about the best hackable camera I can possibly imagine.

That being said, I would be totally on board to help ensure there is accessible, cross-platform software solution for this camera.

Fred-dev has an excellent app for the Mac, written in OpenFrameworks, that allows full access to the camera controls. You can stream out the camera over Syphon (so handy… also, you can control the parameters with OSC (also so handy…

It works great but has a few bugs that cause dropped frames under certain flicker modes. It is also nearly impossible to change resolutions or frame rates. It is also not very sharable as the app is dependent on where it is located in the file structure. However, it still rocks!

To my knowledge this is the only "double-clickable" app that allows for access to the PS3 Eye on the Mac without getting your hands dirty and typing fresh OpenFrameworks or Cinder C++ code.

To summarize, I think these two actions would be very useful.

1) A working driver to be used in creating fresh apps (like the one LSKA mentioned) (For Experts)

2) Simple App for accessing, controlling, and streaming the camera to other apps. (For Beginners)

3) Methods for making plugins available to all of the favorite IDE’s (I.e. Max, Processing, Quartz Composer)

Let’s talk more about this :)

Viewing 16 posts - 1 through 16 (of 16 total)

Forums > MaxMSP