Unable to link Live and Max (macOS High Sierra)


    Sep 26 2017 | 8:09 pm
    I have a fresh install of macOS High Sierra (64bit), with fresh installs of Live 9.7.4 (64bit) and Max 7.3.4.
    M4L devices insist I'm using the wrong version of Max, and that a 32bit version is loaded with Live. I've already tried to completely uninstall/reinstall, noting the warning about leaving Live's DMG mounted while installing Max. Interestingly, the same thing happens when launching a 32bit instance of Live 9.7.4. Attached is a screen shot of the configuration and symptom.
    Not sure if Ableton/C74 is aware of this issue, as they stated there were no known issues with High Sierra, but it obviously causes a lot of problems for those of us who rely on M4L devices. I'm wondering if we'll have to wait for Live 9.7.5 later in October, or if a hotfix can be made for Max?

    • Sep 26 2017 | 10:44 pm
      Same boat here.
      Fresh install of Live (9.7.4) and Max (7.3.4). I´ve tried everything. It does not work in macOS High Sierra fresh install.
      Running on a Macbook Pro 2017 13" Kabylake
      Funny thing. I´ve tried in macOS Sierra and it works flawlessly. So... Come on and fix this thing. Many of us rely heavily on M4Live devices.
    • Sep 26 2017 | 10:58 pm
      Looking at the image you provided, it appears that Max is running in 32-bit mode, Live in 64-bit. Here is something you might try: Open Finder, navigate to /Applications and ‘Get Info’ (in Edit menu) for Max.app. The little box labelled ‘Open in 32-bit mode’ should not be ticked, so untick it if is ticked. With both Live and Max running in 64-bit mode I am not (yet) having any issues. Of course, if you use any Max objects that only support 32-bits this might cause other problems.
    • Sep 26 2017 | 11:08 pm
      I switch the app to Rin in 64 bit. With no success. It does not work. Also, It doesn’t work with older version (6.1.10) in 64 bit. Something is broken there by High Sierra
    • Sep 26 2017 | 11:13 pm
      Sorry to hear that. As I say, Live, Max and M4L are all working for me on High Sierra, so it must be some issue that is not universal. I do know that High Sierra removed support for some older 32-bit apps, so I was guessing this might have affected the 32-bit version of Max. Apparently not.
    • Sep 26 2017 | 11:21 pm
      I hoy this answer from tech support in Cycling
      Cory (Cycling '74 Support) Sep 26, 15:59 PDT
      Hi Dario,
      This is a really vexing issue that seems to happen if you launch Max for Live for the first time when the disk image is still open. After that we have not found any way to force the OS to launch the proper version of Max (it points to the quarantine location created as part of the AppTranslocation feature of 10.12 and 10.13). The only solution we know of at this point is a clean install of the OS. From there, you have to make sure to install Live and max, unmount both disk images and restart, then launch Live and Max for Live.
      We are working on finding a solution, but so far nothing else has worked.
      All the best,
      Cory
      I’m sick of clean install the OS in my machine. It’s exhausting
    • Sep 27 2017 | 7:08 am
      So, I did another clean install, apparently for no reason. After OS reinstall, the very first things I did were:
      1. installed Live 64bit,
      2. unmounted the Live DMG,
      3. installed Max,
      4. unmounted the Max DMG,
      5. restarted,
      6. launched Live,
      7. authenticated Live,
      8. drag M4L device to track,
      9. (prompted for password) enter password
      10. device shows that Max could not be loaded, same as before.
      Yeah, I could have waited for C74 to sort this out, but the fact that the only method they thought worked, actually doesn't work, and has just made me waste a bunch of time in hopes of getting this new machine up and running.
      EDIT: For the sake of troubleshooting, since I have this fresh machine, I did another fresh OS install. This time I did not turn on FileVault, and I installed both Live, then Max, then unmounted both DMGs, restarted, launched live, didn't authenticate, added a M4L device to a track. Same result.
    • Sep 27 2017 | 7:21 am
      I will copy/paste same info which I did sent today also to Ableton. I know High Sierra is not yet official supported, but I just tought they want know bugs for future updates.
      "When I add M4L device Ableton will ask mac admin password Version: Max for live Version 7.2.4 (1cf59cb) (32-bit mac) After password, M4L works fine. I did try install newer version of M4L but then it didn’t work at all. M4L device was empty and there was message that maybe you don’t use 64bit version. And it was 64bit."
      So 7.3 M4L won't work me at all, luckily I have backup, where I was able to revert 7.2.4 version which work (it ask still admin password, but I can live with that) I also have issues with Push 2 latency but that is other story :)
    • Sep 27 2017 | 11:34 am
      I have exactly the same issue: "Wrong Max version" on High Sierra. Here is what Ableton tech support answered: "Yes, unfortunately this looks like an issue we've been dealing with in Sierra, and it seems that it hasn't yet been fixed in High Sierra. There are some terminal commands you could try, although the only thing that I've personally seen work is a clean install of the OS."
    • Sep 27 2017 | 4:42 pm
      I can only second the problem ... I had latest Live and an older Version of Max installed (7.0x I think) then updated to macOs10.13 and on Ableton Live start I got asked for password (as I have a M4L device in my default template) and then that I need to install JR6 - wich I did but I still had to enter my password ... but I think the M4L devices were working then after installing Max7.3x and updating to JR8 I had to enter my password and no M4L device was working anymore
      I don't want to spend further time on it and wait for a fix
    • Sep 28 2017 | 3:13 pm
      Same problem here. This is appearing at the worst possible time I can imagine... Hoping for a fix ASAP
    • Sep 28 2017 | 4:06 pm
      Here it is curios: my MBP , running Live 9.7.4 and M4L 7.3.4 works after upgrade to 10.13 with the password question - all works without known problems. BUT: my iMac, clean install 4 weeks ago with 10.12, install all fresh (Live, M4L, others) - now upgrade to 10.13 have the same problem like the others here. It's now task for Ableton/Cycling74 to fix this problem fastest. They all know about release a new macos version and there was enough time to check the operation with the new os. I have no understand for doing this just and not earlier.
    • Sep 28 2017 | 5:07 pm
      Hi Everyone, sorry for the issues you are all experiencing.
      We've been in touch with Ableton about this issue and it appears to be related to how 10.13 is handling code-signing of 3rd party apps, in this case Max within Live. The Ableton team is working on a fix and, while we hope it will be coming soon, cannot provide a timeline.
      While the issue seemed at first to be the same as an earlier issue from 10.12, it is not identical and even a clean install of the OS does not appear to be a viable fix.
      In the meantime, the only recommendation that we can give is to downgrade to 10.12 for any timing critical M4L work or to wait for an update to Live if you can.
    • Oct 02 2017 | 8:19 am
      Thanks for that information! I was anyway only testing high Sierra. So I'm fine waiting a bit and continue using M4L under Sierra.
    • Oct 04 2017 | 7:09 am
      I have the same issue on my Macbook Pro and have tried fresh installs and nothing works. Crazy thing is my office computer (MacPro) with same update has no issues.
    • Oct 04 2017 | 10:10 am
      I have the same problem. My work is stopped... How long will we wait?
    • Oct 04 2017 | 9:00 pm
      Ableton have posted on their compatibility page:
      We ensure full compatibility with Live 9.7.5, due for release in mid-October 2017
      In the meantime, if you are still having trouble please contact support@cycling74.com and we will see if we can help you with a workaround.
    • Oct 04 2017 | 9:35 pm
      Is there a workaround with a clean install yet Cory, or just migrating using so setup assistant?
    • Oct 05 2017 | 3:03 am
      I think the trick might be to first install and run Live/Max on Sierra. Then update to HS.
      This ended up working for me.
    • Oct 05 2017 | 8:56 am
      Received the following from Ableton Support. I can confirm that the following works as a hotfix for me.
      ---
      Regarding the issue with High Sierra and Max for Live we have found a workaround that seems to work for all affected users so far.
      Should you consider following this instructions please understand that you try this at your at your own risk. 
      You would have to copy some files manually into the Live.app.
      To do so please follow these instructions:
      - Make sure Live 9.7.4 64-bit and Max 7.3.4 are installed in your Applications folder and are not running - Download this file. - Unzip it to a folder and leave that finder window open - Open a new finder window and go to your Applications folder - Right click on the Live.app and select Show Package Contents
      - Place the Frameworks folder that you unpacked before in the Contents folder of the Live.app, so that it looks like on the screenshot below​
      As soon as you load a Max device you'd still be asked for your password, but the device should load afterwards.
      Please note that this workaround is not a final solution and doesn't substitute doing a proper upgrade to Live 9.7.5 when it is released later in October. Further it might not work for customers with a 32-bit version of Live. 
      Should this not solve your issue please let us know, so that we can investigate further.
      We'll inform you as soon as there are any news on the subject.
      Please note that this is an email that is send to all affected customers.  Don't hesitate to ask directly should there be questions or problems.
      All the best, Will Tech Support
    • Oct 05 2017 | 9:25 am
      Yes, I got same and it works for me.
    • Oct 05 2017 | 10:30 am
      Someone can confirm that this hotfix from Ableton works? Someone already tried? Please let us know. It would be a useful temporary solutionb until 9.7.5
    • Oct 05 2017 | 10:32 am
      Yes, it works exactly as described: "As soon as you load a Max device you'd still be asked for your password, but the device should load afterwards."
    • Oct 05 2017 | 10:33 am
      I got that email too. I have not tried yet.
    • Oct 05 2017 | 12:51 pm
      works like a charm, good job.
    • Oct 05 2017 | 7:25 pm
      I can confirm that the hotfix works. Many thanks and we will be waiting the 9.7.5 iteration of Live
    • Oct 08 2017 | 11:30 am
      Convolution Reverb doesn't work... Plugin has opened but don't work.
    • Oct 08 2017 | 3:20 pm
      Many Thanks Andre, works perfect to me, I hope we'll have a proper solution late October, in the mean time this is a great option to continue working. Thanks a lot!
    • Oct 10 2017 | 12:10 pm
      Hi, after installing the fix: The LFO device and many others when trying to load them lead to the closing of the program, the convolution reverb device does not see and does not display impulses!
    • Oct 18 2017 | 8:17 am
      This doesn't work with all Max devices. For example with the synth "Model 55" Live will CRASH
    • Oct 19 2017 | 9:15 am
      I got this answer from Ableton when I noticed that e.g MidiVolve device crashed. This worked for me.
      - Open the Max.app via Show Package Contents  - Go to Content and copy the Frameworks folder from here - Navigate to your Ableton Live.app - Show package Contents ---> Content - Delete the other Frameworks folder and paste the one you copied from the Max.app - Give it another try
    • Oct 19 2017 | 9:37 am
      in Live there is no Frameworksfolder but coping the one from Max is making the Max-plugins work ... the password has still to be entered
    • Oct 19 2017 | 9:40 am
      Yes, password issue is valid also after workaround. I think (hope) that will be fixed on official update.
    • Oct 23 2017 | 2:40 pm
      9.7.5 iteration of Live installed and still have the same issue.
    • Oct 23 2017 | 2:49 pm
      Ok, just did what JII75 said in previous post and it worked.
      One difference: "Navigate to your Ableton Live.app - Show package Contents ---> Content - Delete the other Frameworks folder and paste the one you copied from the Max.app - " ( there was no Frameworks folder in my Ableton 9.7.5)
      I just copied the Frameworks folder from making and pasted it in Ableton and it worked.
    • Oct 23 2017 | 4:56 pm
      Hello! Is anyone still having this issue? I have installed max for live and there was conflict,ihave pasted frameworks into Ableton content folder and it got a little better but still Ableton crashes when cam clicking on devices... Please help!
    • Oct 23 2017 | 9:16 pm
    • Oct 24 2017 | 8:02 am
      I will copy/paste same info which I did sent today also to Ableton. I know High Sierra is not yet official supported, but I just tought they want know bugs for future updates.
    • Oct 24 2017 | 9:11 am
      awesome - it works -thanks!