GPU Feedback problem with Mavericks OS X 10.9 // FBO vs. RTT

    Feb 20 2014 | 6:33 pm
    Hi guys, so I just upgraded to Mavericks and have discovered a very strange problem that I have no way of explaining. Hopefully someone here can shed some light on this issue.
    I opened Andrew Benson's very nice hsflow-distort patch and opened the webcam. Everything opened normally as usual. But as soon as I switch to a video, a large, black blob begins to form, seemingly some type of feedback artifact, and bleeds out the entire image. If I go back to the webcam, and reset the window (by entering/exiting fullscreen), everything is OK again, and works perfectly fine.
    Has anyone else experienced this type of problem?
    I would like to note that I've tried the same thing on a Mac running OSX 10.8 and there is no such problem.
    I've attached Andrew's patch with the shaders, and a patch that lets you switch between webcam and video to help illustrate the issue [hsflow-0rtyf@xVideoSwitch.maxpat]
    I'm running a 2.2 GHz Intel Core i7 8 GB MacbookPro AMD Radeon HD 6750M Graphics Card Max 6.1.6

    • Feb 21 2014 | 3:58 am
      I'm running Mavericks on an older Macbook Pro (Core2 Duo 2.4GHz) and your patch seems fine in MAX 6.1.6 running in 32 bit mode. I'm using the "old" grabber though. I wonder if that's related? Look in the "MAX 6.1.6 Released" thread for info about the new QTKit grabber and how to switch back to the old one to avoid possible image corruption:
    • Feb 21 2014 | 9:52 pm
      Thank you for pointing me towards this info about the new QTKit -- definitely useful information to know in the future.
      But I think you may have mistaken my issue -- I'm having no issue with the grabber, it's when you switch from jit.qt.grab to that the bleeding feedback artifact appears (which is part of the reason why it's so strange to me, I don't understand why there should be any major difference between the webcam output and a .mov). If you look in the patch marked hsflow_0rty@xVideoSwitch it allows you to switch from the grabber to the movie file, in this case I'm using the standard file but i've tried a variety of different videos of various resolutions and codecs, and they all produce the same result. If you try running the patch with a movie file, does everything run smoothly for you?
    • Feb 22 2014 | 8:38 pm
      My apologies. I mis-read the post!
      I get totally normal behavior with the movie or the webcam on my system (Mavericks 10.9.1, older "Santa Rosa" MacBook Pro, MAX 6.1.6 in 32-bit mode).
      Hopefully somebody can reproduce the problem.
    • Feb 23 2014 | 4:54 pm
      Thanks for the help! -- I've figured out a solution to the problem, hopefully somebody can help shed some light on the reason for this behavior so I can understand the underlying issue in future problems -- I still don't understand why this problem occurred for me only when moving to OSX 10.9, or why a movie vs. the grabber makes a difference.
      Also I've simplified the patch to exclude all of Andrew's shaders, to show that this is a general problem with slab feedback, meaning it could potentially negatively affect a lot of Jitter users work.
      So when I set the glreadback from the fbo (frame buffer object) to rtt (read to texture), everything runs as it should, the way it did before I upgraded to OSX 10.9. if I switch to fbo, then the feedback artifact appears again. but for some reason it still only happens with movie files and not with the webcam.
      ZLP, in your preferences is your default GL Readback set to fbo or rtt?
      I've also tested the patch in Max 5 on OSX 10.9, and without switching to rtt everything runs as it should. but, just like in max6 when I switch the readback to fbo the artifact appears. does anyone know if max5 is set to rtt by default?
      Here is a patch that allows you switch between the readback settings to illustrate the problem.
    • Feb 23 2014 | 5:37 pm
      I'm sorry, I made a mistake -- the problem doesn't persist without Andrew's shaders. So it does seem like problem with optical flow shaders and OS X 10.9
      example here:
    • Feb 23 2014 | 5:45 pm
      For what it's worth, my prefs are set to FBO and it works fine here. (My GPU is NVIDIA GeForce 8600M GT 256 MB)
    • Oct 23 2014 | 1:39 pm
      Hi ZLP, Just wondering whether you ever got to the bottom of this one I've had a similar problem with the optical flow shaders, this time on a new Mac Pro. Works fine on my Macbook Pro under the same OS.
    • Oct 23 2014 | 8:39 pm
      Tom W. I'm not the original poster. I couldn't reproduce the problem on my machine. Good luck.